summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-02-08 23:09:23 +0000
committerVlastimil Babka <caster@gentoo.org>2011-02-08 23:09:23 +0000
commit38194b6cd30ba4f1b38c95531c08d4b0001b43d1 (patch)
tree3497453ef317c43a4d411a71a9a3a272bb83e522 /app-office/taskcoach
parentAdd src_install to drop unneeded la files. Drop old revisions. (diff)
downloadgentoo-2-38194b6cd30ba4f1b38c95531c08d4b0001b43d1.tar.gz
gentoo-2-38194b6cd30ba4f1b38c95531c08d4b0001b43d1.tar.bz2
gentoo-2-38194b6cd30ba4f1b38c95531c08d4b0001b43d1.zip
Version bump.
(Portage version: 2.2.0_alpha21/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-1.2.9.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index f2c7508b2148..cd5ecae0b796 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.67 2011/01/24 15:45:43 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.68 2011/02/08 23:09:23 caster Exp $
+
+*taskcoach-1.2.9 (08 Feb 2011)
+
+ 08 Feb 2011; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.2.9.ebuild:
+ Version bump.
*taskcoach-1.2.8 (24 Jan 2011)
diff --git a/app-office/taskcoach/taskcoach-1.2.9.ebuild b/app-office/taskcoach/taskcoach-1.2.9.ebuild
new file mode 100644
index 000000000000..7da9020dfc5b
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.2.9.ebuild,v 1.1 2011/02/08 23:09:23 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}