summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-03-16 08:34:29 +0000
committerVlastimil Babka <caster@gentoo.org>2010-03-16 08:34:29 +0000
commit181d4fb9a2e80b2f02af122351f2f885e048cc78 (patch)
tree72e5edcc1e61f908303ef1fc37d105f1082852bd /app-office/taskcoach/taskcoach-0.78.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-181d4fb9a2e80b2f02af122351f2f885e048cc78.tar.gz
gentoo-2-181d4fb9a2e80b2f02af122351f2f885e048cc78.tar.bz2
gentoo-2-181d4fb9a2e80b2f02af122351f2f885e048cc78.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach/taskcoach-0.78.4.ebuild')
-rw-r--r--app-office/taskcoach/taskcoach-0.78.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-office/taskcoach/taskcoach-0.78.4.ebuild b/app-office/taskcoach/taskcoach-0.78.4.ebuild
new file mode 100644
index 000000000000..9fdab149dfaf
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-0.78.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.78.4.ebuild,v 1.1 2010/03/16 08:34:29 caster Exp $
+
+EAPI=1
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# disappeared in 0.73.2, maybe will appear again?
+#DOCS="CHANGES.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ elog "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_compile() {
+ # upstream now sets executable to /usr/bin/python2.5
+ distutils_src_compile --executable=/usr/bin/python
+}
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}