summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-12 19:28:40 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-12 19:28:40 +0000
commit5d6f05d941bc33302209286c0c8e37f38fb09817 (patch)
treefd1f8d4811cd5bc3192c4b355509762a8c8f2661 /app-office/skrooge
parentStable for amd64 wrt bug #502642 (diff)
downloadgentoo-2-5d6f05d941bc33302209286c0c8e37f38fb09817.tar.gz
gentoo-2-5d6f05d941bc33302209286c0c8e37f38fb09817.tar.bz2
gentoo-2-5d6f05d941bc33302209286c0c8e37f38fb09817.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-office/skrooge')
-rw-r--r--app-office/skrooge/ChangeLog7
-rw-r--r--app-office/skrooge/skrooge-1.9.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-office/skrooge/ChangeLog b/app-office/skrooge/ChangeLog
index 912f58c4de7e..1f22d66d407b 100644
--- a/app-office/skrooge/ChangeLog
+++ b/app-office/skrooge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/skrooge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/ChangeLog,v 1.53 2014/01/31 15:53:05 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/ChangeLog,v 1.54 2014/04/12 19:28:40 johu Exp $
+
+*skrooge-1.9.0 (12 Apr 2014)
+
+ 12 Apr 2014; Johannes Huber <johu@gentoo.org> +skrooge-1.9.0.ebuild:
+ Version bump.
31 Jan 2014; Johannes Huber <johu@gentoo.org> -skrooge-1.7.1.ebuild:
Remove old.
diff --git a/app-office/skrooge/skrooge-1.9.0.ebuild b/app-office/skrooge/skrooge-1.9.0.ebuild
new file mode 100644
index 000000000000..0c6f51817575
--- /dev/null
+++ b/app-office/skrooge/skrooge-1.9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/skrooge/skrooge-1.9.0.ebuild,v 1.1 2014/04/12 19:28:40 johu Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fi fr ga gl hu ia
+it ja ko lt mr ms nb nds nl pl pt pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="personal finances manager for KDE4, aiming at being simple and intuitive"
+HOMEPAGE="http://www.skrooge.org/"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ app-crypt/qca:2
+ dev-db/sqlite:3
+ dev-libs/grantlee
+ >=dev-libs/libofx-0.9.1
+ dev-libs/qjson
+ dev-qt/qtsql:4[sqlite]
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kde-dev-scripts)
+"
+
+# upstream does not ship tests in releases
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ RESTRICT="test"
+fi
+
+DOCS=( AUTHORS CHANGELOG README TODO )
+
+src_prepare() {
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_test() {
+ local mycmakeargs=(
+ -DSKG_BUILD_TEST=ON
+ )
+ kde4-base_src_test
+}