summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 18:24:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 18:24:49 +0000
commit4ec7b2f31588065215ff83ec8095f70a47c6e75d (patch)
treea8f8a8f06ac4f3a5b4a19368798ba4ac6cc66033 /app-office/rubrica
parentUse.mask quvi (diff)
downloadgentoo-2-4ec7b2f31588065215ff83ec8095f70a47c6e75d.tar.gz
gentoo-2-4ec7b2f31588065215ff83ec8095f70a47c6e75d.tar.bz2
gentoo-2-4ec7b2f31588065215ff83ec8095f70a47c6e75d.zip
Fix building with x11-libs/libnotify >= 0.7. Remove useless .la files.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-office/rubrica')
-rw-r--r--app-office/rubrica/ChangeLog8
-rw-r--r--app-office/rubrica/files/rubrica-2.1.6-libnotify-0.7.patch20
-rw-r--r--app-office/rubrica/rubrica-2.1.6-r1.ebuild63
3 files changed, 62 insertions, 29 deletions
diff --git a/app-office/rubrica/ChangeLog b/app-office/rubrica/ChangeLog
index b2ecc976be23..8e791fa99f84 100644
--- a/app-office/rubrica/ChangeLog
+++ b/app-office/rubrica/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/rubrica
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/rubrica/ChangeLog,v 1.14 2010/12/17 16:27:20 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/rubrica/ChangeLog,v 1.15 2011/01/30 18:24:48 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> rubrica-2.1.6-r1.ebuild,
+ +files/rubrica-2.1.6-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7. Remove useless .la files.
17 Dec 2010; Christian Faulhammer <fauli@gentoo.org> metadata.xml:
Drop maintainership
diff --git a/app-office/rubrica/files/rubrica-2.1.6-libnotify-0.7.patch b/app-office/rubrica/files/rubrica-2.1.6-libnotify-0.7.patch
new file mode 100644
index 000000000000..9ab854aff20a
--- /dev/null
+++ b/app-office/rubrica/files/rubrica-2.1.6-libnotify-0.7.patch
@@ -0,0 +1,20 @@
+--- src/app.c
++++ src/app.c
+@@ -1338,8 +1338,15 @@
+ self->priv->statusbar = rubrica_statusbar_new();
+
+ self->priv->cutted = NULL;
+- self->priv->notify = notify_notification_new("Rubrica Addressbook",
+- NULL, "info", NULL);
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ self->priv->notify = notify_notification_new("Rubrica Addressbook", NULL, "info");
++#else
++ self->priv->notify = notify_notification_new("Rubrica Addressbook", NULL, "info", NULL);
++#endif
++#else
++ self->priv->notify = notify_notification_new("Rubrica Addressbook", NULL, "info", NULL);
++#endif
+ self->priv->active_plugin = g_strdup("autodetect");
+ self->priv->manager = r_lib_get_manager();
+ self->priv->print_settings = NULL;
diff --git a/app-office/rubrica/rubrica-2.1.6-r1.ebuild b/app-office/rubrica/rubrica-2.1.6-r1.ebuild
index 25cf21438b02..9ddfcf9e134e 100644
--- a/app-office/rubrica/rubrica-2.1.6-r1.ebuild
+++ b/app-office/rubrica/rubrica-2.1.6-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/rubrica/rubrica-2.1.6-r1.ebuild,v 1.4 2009/06/20 23:22:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/rubrica/rubrica-2.1.6-r1.ebuild,v 1.5 2011/01/30 18:24:48 ssuominen Exp $
-EAPI=1
-
-inherit gnome2 eutils
+EAPI=2
+inherit eutils gnome2
MY_PN=${PN}2
@@ -13,34 +12,41 @@ HOMEPAGE="http://rubrica.berlios.de/"
SRC_URI="mirror://berlios/${PN}/${MY_PN}-${PV}.tar.bz2
linguas_hu? ( mirror://gentoo/${P}-hu.po.bz2 )"
-IUSE="linguas_hu"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86"
-LICENSE="GPL-3"
-
-DOCS="AUTHORS ChangeLog CREDITS INSTALL NEWS README TODO"
-S=${WORKDIR}/${MY_PN}-${PV}/
+IUSE="linguas_hu"
-RDEPEND="dev-libs/libxml2
- gnome-base/libglade
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ >=gnome-base/libglade-2
gnome-base/gconf:2
- dev-perl/XML-Parser
- x11-libs/libnotify
- linguas_hu? ( >=sys-devel/gettext-0.16.1 )"
-
+ x11-libs/gtk+:2
+ x11-libs/libnotify"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/intltool
+ dev-util/pkgconfig
+ linguas_hu? ( >=sys-devel/gettext-0.16.1 )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-static
+ --with-html-dir=/usr/share/doc/${PF}/html"
-src_unpack() {
- gnome2_src_unpack
- cd "${S}"
+ DOCS="AUTHORS ChangeLog CREDITS NEWS README TODO"
+}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
# False menu in locales
- epatch "${FILESDIR}/${P}_fix-menu-language.patch"
+ epatch "${FILESDIR}"/${P}_fix-menu-language.patch
# Missing gnome icons
- epatch "${FILESDIR}/${P}_missing-icons.patch"
- cd "${S}/po"
- epatch "${FILESDIR}/${P}_url-crash.patch"
+ epatch "${FILESDIR}"/${P}_missing-icons.patch
+ cd po
+ epatch "${FILESDIR}"/${P}_url-crash.patch
}
src_compile() {
@@ -48,16 +54,19 @@ src_compile() {
# Add Hungarian translation
if use linguas_hu; then
- msgfmt "${WORKDIR}/${P}-hu.po" --output-file "po/hu.gmo" || die
+ msgfmt "${WORKDIR}"/${P}-hu.po --output-file po/hu.gmo || die
fi
}
src_install() {
gnome2_src_install
- domenu "${FILESDIR}/${MY_PN}.desktop"
+ domenu "${FILESDIR}"/${MY_PN}.desktop
+
if use linguas_hu; then
domo po/hu.gmo || die
- dosym "${PN}.mo" "/usr/share/locale/hu/LC_MESSAGES/${MY_PN}.mo"
+ dosym ${PN}.mo /usr/share/locale/hu/LC_MESSAGES/${MY_PN}.mo || die
fi
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}