summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-01-04 19:55:14 +0000
committerPacho Ramos <pacho@gentoo.org>2012-01-04 19:55:14 +0000
commit0dcca69d8be6e1a34e8e4294c430e85134f79e53 (patch)
tree2ceb42052db653b1b5faa329c8a93c47fd1a2319 /app-office/planner
parentMarking star-1.5.1-r1 ppc for bug 393905 (diff)
downloadgentoo-2-0dcca69d8be6e1a34e8e4294c430e85134f79e53.tar.gz
gentoo-2-0dcca69d8be6e1a34e8e4294c430e85134f79e53.tar.bz2
gentoo-2-0dcca69d8be6e1a34e8e4294c430e85134f79e53.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/ChangeLog10
-rw-r--r--app-office/planner/files/planner-0.14.6-find-python.patch19
-rw-r--r--app-office/planner/planner-0.14.6.ebuild76
3 files changed, 103 insertions, 2 deletions
diff --git a/app-office/planner/ChangeLog b/app-office/planner/ChangeLog
index beee9e3fe1a8..b82eb57e3bdf 100644
--- a/app-office/planner/ChangeLog
+++ b/app-office/planner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/planner
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.62 2011/07/14 17:26:34 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.63 2012/01/04 19:55:14 pacho Exp $
+
+*planner-0.14.6 (04 Jan 2012)
+
+ 04 Jan 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/planner-0.14.6-find-python.patch, +planner-0.14.6.ebuild:
+ Version bump.
14 Jul 2011; Pacho Ramos <pacho@gentoo.org> -planner-0.14.4.ebuild:
Remove old.
diff --git a/app-office/planner/files/planner-0.14.6-find-python.patch b/app-office/planner/files/planner-0.14.6-find-python.patch
new file mode 100644
index 000000000000..60f503a88875
--- /dev/null
+++ b/app-office/planner/files/planner-0.14.6-find-python.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4.old 2011-07-05 14:33:18.000000000 +0200
++++ acinclude.m4 2011-07-05 14:34:23.000000000 +0200
+@@ -85,14 +85,8 @@
+
+ # Check for Python library path
+ AC_MSG_CHECKING([for Python library path])
+- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- break
+- fi
+- done
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
++ [python_path=`$PYTHON -c 'import distutils.sysconfig, os; \
++ print(os.path.sep.join(distutils.sysconfig.get_python_lib(standard_lib=True).split(os.path.sep)[:-1]))'`]
+ AC_MSG_RESULT([$python_path])
+ if test -z "$python_path" ; then
+ AC_MSG_ERROR([cannot find Python library path])
diff --git a/app-office/planner/planner-0.14.6.ebuild b/app-office/planner/planner-0.14.6.ebuild
new file mode 100644
index 000000000000..0da742295280
--- /dev/null
+++ b/app-office/planner/planner-0.14.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.6.ebuild,v 1.1 2012/01/04 19:55:13 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2"
+
+inherit python gnome2 eutils autotools
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="http://live.gnome.org/Planner/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc eds python examples"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.14:2
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4:2.0
+ >=gnome-base/gconf-2.6:2
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ python? ( >=dev-python/pygtk-2.6:2 )
+ eds? (
+ >=gnome-extra/evolution-data-server-1.1
+ >=mail-client/evolution-2.1.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.5
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common"
+
+# FIXME: disable eds backend for now, it fails, upstream bug #654005
+pkg_setup() {
+ DOCS="AUTHORS COPYING ChangeLog NEWS README"
+ G2CONF="${G2CONF}
+ $(use_enable python)
+ $(use_enable python python-plugin)
+ $(use_enable eds)
+ --disable-eds-backend
+ --with-database=no
+ --disable-update-mimedb"
+ #$(use_enable eds eds-backend)
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Find python in a faster way, bug #344231, upstream bug #654044
+ epatch "${FILESDIR}/${PN}-0.14.6-find-python.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}