summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-08-24 06:27:38 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-08-24 06:27:38 +0000
commitea0261aea83fbaea76f3f9aa782c6200aa6b4e9c (patch)
treef2b036eb98633a47aefa5eebec5a7c7dc33c1868 /app-office/pinpoint
parentAlso apply fix for bug 343693. (diff)
downloadgentoo-2-ea0261aea83fbaea76f3f9aa782c6200aa6b4e9c.tar.gz
gentoo-2-ea0261aea83fbaea76f3f9aa782c6200aa6b4e9c.tar.bz2
gentoo-2-ea0261aea83fbaea76f3f9aa782c6200aa6b4e9c.zip
Initial version of the handly little presentation tool.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/ChangeLog10
-rw-r--r--app-office/pinpoint/metadata.xml19
-rw-r--r--app-office/pinpoint/pinpoint-0.1.2.ebuild45
3 files changed, 74 insertions, 0 deletions
diff --git a/app-office/pinpoint/ChangeLog b/app-office/pinpoint/ChangeLog
new file mode 100644
index 000000000000..bc00dda5e389
--- /dev/null
+++ b/app-office/pinpoint/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-office/pinpoint
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/ChangeLog,v 1.1 2011/08/24 06:27:38 ford_prefect Exp $
+
+*pinpoint-0.1.2 (24 Aug 2011)
+
+ 24 Aug 2011; Arun Raghavan <ford_prefect@gentoo.org> +pinpoint-0.1.2.ebuild,
+ +metadata.xml:
+ Initial version of the handly little presentation tool.
+
diff --git a/app-office/pinpoint/metadata.xml b/app-office/pinpoint/metadata.xml
new file mode 100644
index 000000000000..9f7a74ce8520
--- /dev/null
+++ b/app-office/pinpoint/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ford_prefect@gentoo.org</email>
+ <name>Arun Raghavan</name>
+ </maintainer>
+ <maintainer>
+ <email>nirbheek@gentoo.org</email>
+ <name>Nirbheek Chauhan</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pinpoint is a simple presentation tool that hopes to avoid audience
+ death by bullet point and instead encourage presentations containing
+ beautiful images and small amounts of concise text in slides.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/app-office/pinpoint/pinpoint-0.1.2.ebuild b/app-office/pinpoint/pinpoint-0.1.2.ebuild
new file mode 100644
index 000000000000..d2f6d1364499
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/pinpoint-0.1.2.ebuild,v 1.1 2011/08/24 06:27:38 ford_prefect Exp $
+
+EAPI=4
+
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome.org
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://live.gnome.org/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND=">=media-libs/clutter-1.4:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( >=media-libs/clutter-gst-1.3:1.0 )
+ pdf? ( gnome-base/librsvg:2 )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ econf --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+ fi
+}