summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-10 13:51:02 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-10 13:51:02 +0000
commit541618bdf1f172ce9436a792b4889e31fcf55afc (patch)
tree10df51ced0d59599f36ff14669a07f8d7a0a51fc /app-office/orage
parentRevision bump to 1.4-r1. Added src_unpack to fix an upstream typo. Added a pr... (diff)
downloadgentoo-2-541618bdf1f172ce9436a792b4889e31fcf55afc.tar.gz
gentoo-2-541618bdf1f172ce9436a792b4889e31fcf55afc.tar.bz2
gentoo-2-541618bdf1f172ce9436a792b4889e31fcf55afc.zip
Xfce-4.6 bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/ChangeLog7
-rw-r--r--app-office/orage/orage-4.6.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 84e441649094..015d5cc1d5a4 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/orage
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.13 2009/02/04 18:45:02 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.14 2009/03/10 13:51:02 angelos Exp $
+
+*orage-4.6.0 (10 Mar 2009)
+
+ 10 Mar 2009; Christoph Mende <angelos@gentoo.org> +orage-4.6.0.ebuild:
+ Xfce-4.6 bump
04 Feb 2009; Christoph Mende <angelos@gentoo.org> orage-4.5.14.0.ebuild:
Added missing eautoreconf call
diff --git a/app-office/orage/orage-4.6.0.ebuild b/app-office/orage/orage-4.6.0.ebuild
new file mode 100644
index 000000000000..7a75baa6ba10
--- /dev/null
+++ b/app-office/orage/orage-4.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.6.0.ebuild,v 1.1 2009/03/10 13:51:02 angelos Exp $
+
+EAPI=1
+
+inherit xfce4
+
+xfce4_core
+
+DESCRIPTION="Calendar suite for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/orage/"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb dbus debug libnotify"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-base/xfce4-panel-${XFCE_VERSION}
+ berkdb? ( >=sys-libs/db-4 )
+ libnotify? ( x11-libs/libnotify )
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.5"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable dbus) $(use_enable libnotify)
+ $(use_with berkdb bdb4) --disable-libxfce4mcs"
+}
+
+pkg_postinst() {
+ xfce4_pkg_postinst
+
+ elog
+ elog "There is no migration support from 4.4 to 4.5,"
+ elog "you need to copy your Orage files manually."
+ elog
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"