summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-21 11:24:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-21 11:24:38 +0000
commit09fe5992c4f09ee14a0af4b64b875b4f336ca94f (patch)
treea6c8f127cd9d59c4f8dc4071f25773a617f1ead3 /app-office/orage
parentForce recent enough desktop-file-utils to validate XFCE in Categories. (diff)
downloadgentoo-2-09fe5992c4f09ee14a0af4b64b875b4f336ca94f.tar.gz
gentoo-2-09fe5992c4f09ee14a0af4b64b875b4f336ca94f.tar.bz2
gentoo-2-09fe5992c4f09ee14a0af4b64b875b4f336ca94f.zip
Install xfce4-orageclock-plugin to libdir instead of libexecdir. Fix documentation installation path.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/ChangeLog6
-rw-r--r--app-office/orage/orage-4.8.3.ebuild25
2 files changed, 24 insertions, 7 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 270001370eed..ec038b4710bb 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/orage
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.61 2012/04/17 07:37:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.62 2012/04/21 11:24:38 ssuominen Exp $
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> orage-4.8.3.ebuild:
+ Install xfce4-orageclock-plugin to libdir instead of libexecdir. Fix
+ documentation installation path.
17 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -orage-4.8.2.ebuild:
old
diff --git a/app-office/orage/orage-4.8.3.ebuild b/app-office/orage/orage-4.8.3.ebuild
index 82a61966f04f..59c1d0ff1313 100644
--- a/app-office/orage/orage-4.8.3.ebuild
+++ b/app-office/orage/orage-4.8.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.3.ebuild,v 1.5 2012/02/13 21:34:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.3.ebuild,v 1.6 2012/04/21 11:24:38 ssuominen Exp $
EAPI=4
-inherit xfconf
+inherit multilib xfconf
DESCRIPTION="A time managing application (and panel plug-in) for the Xfce desktop environment"
-HOMEPAGE="http://www.xfce.org/projects/orage/"
+HOMEPAGE="http://www.xfce.org/projects/"
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -18,15 +18,16 @@ RDEPEND=">=dev-libs/libical-0.48
dev-libs/popt
>=x11-libs/gtk+-2.10:2
berkdb? ( >=sys-libs/db-4 )
- dbus? ( >=dev-libs/dbus-glib-0.90 )
+ dbus? ( >=dev-libs/dbus-glib-0.98 )
libnotify? ( >=x11-libs/libnotify-0.7 )
xfce_plugins_clock? ( >=xfce-base/xfce4-panel-4.8 )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig"
pkg_setup() {
XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
--docdir="${EPREFIX}"/usr/share/doc/${PF}/html
$(use_enable xfce_plugins_clock libxfce4panel)
$(use_enable dbus)
@@ -36,4 +37,16 @@ pkg_setup() {
)
DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+ # PM doesn't let directory to be replaced by a symlink, see src_install()
+ rm -rf "${EROOT}"/usr/share/${PN}/doc
+}
+
+src_install() {
+ xfconf_src_install \
+ docdir=/usr/share/doc/${PF}/html \
+ imagesdir=/usr/share/doc/${PF}/html/images
+
+ # Create compability symlink for retarded path hardcoding in src/{mainbox,parameters}.c
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/doc/C
}