summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2006-01-25 06:40:36 +0000
committerAndreas Proschofsky <suka@gentoo.org>2006-01-25 06:40:36 +0000
commit735788a0870217b80a1e040c83913b056b3a28a6 (patch)
tree4aece16e7cde8b47629f418d4071dfdd8def0237 /app-office/openoffice/openoffice-2.0.1.ebuild
parent(#117230) Add modular X deps. (diff)
downloadgentoo-2-735788a0870217b80a1e040c83913b056b3a28a6.tar.gz
gentoo-2-735788a0870217b80a1e040c83913b056b3a28a6.tar.bz2
gentoo-2-735788a0870217b80a1e040c83913b056b3a28a6.zip
reshuffle the ebuild a little bit
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-office/openoffice/openoffice-2.0.1.ebuild')
-rw-r--r--app-office/openoffice/openoffice-2.0.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-office/openoffice/openoffice-2.0.1.ebuild b/app-office/openoffice/openoffice-2.0.1.ebuild
index f6ba25bfc251..8abeace4121a 100644
--- a/app-office/openoffice/openoffice-2.0.1.ebuild
+++ b/app-office/openoffice/openoffice-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-2.0.1.ebuild,v 1.17 2006/01/22 20:12:27 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-2.0.1.ebuild,v 1.18 2006/01/25 06:40:36 suka Exp $
inherit eutils fdo-mime flag-o-matic kde-functions toolchain-funcs
@@ -129,6 +129,9 @@ pkg_setup() {
epause 10
fi
+ #Detect which look and patchset we are using, amd64 is known not to be working atm, so this is here for testing purposes only
+ use amd64 && export DISTRO="Gentoo64" || export DISTRO="Gentoo"
+
}
src_unpack() {
@@ -141,9 +144,6 @@ src_unpack() {
cp ${FILESDIR}/${PV}/gentoo-gcc-version.diff ${S}/patches/src680/ || die
epatch ${FILESDIR}/${PV}/gentoo-${PV}.diff
- #Detect which look and patchset we are using, amd64 is known not to be working atm, so this is here for testing purposes only
- use amd64 && export DISTRO="Gentoo64" || export DISTRO="Gentoo"
-
#Use flag checks
use java && echo "--with-jdk-home=${JAVA_HOME} --with-ant-home=${ANT_HOME}" >> ${CONFFILE} || echo "--without-java" >> ${CONFFILE}