summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-09-20 13:49:28 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-09-20 13:49:28 +0000
commitadb6e04d19c613b40dfcacbf7b370a2558881656 (patch)
treee674fc98e4d82fa8a0ae1c34306ba544024dac62 /app-office/openoffice/files
parentStable for ppc. (diff)
downloadgentoo-2-adb6e04d19c613b40dfcacbf7b370a2558881656.tar.gz
gentoo-2-adb6e04d19c613b40dfcacbf7b370a2558881656.tar.bz2
gentoo-2-adb6e04d19c613b40dfcacbf7b370a2558881656.zip
Fix build with sys-libs/db-4.8, bug #285544
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'app-office/openoffice/files')
-rw-r--r--app-office/openoffice/files/dbfix.diff27
-rw-r--r--app-office/openoffice/files/gentoo-3.1.1.diff22
2 files changed, 48 insertions, 1 deletions
diff --git a/app-office/openoffice/files/dbfix.diff b/app-office/openoffice/files/dbfix.diff
new file mode 100644
index 000000000000..776248c33f21
--- /dev/null
+++ b/app-office/openoffice/files/dbfix.diff
@@ -0,0 +1,27 @@
+--- configure.in.orig
++++ configure.in
+@@ -3932,23 +3932,6 @@
+ if test "$DB_INCLUDES" = ""; then
+ AC_MSG_ERROR(no. install the db4-dev package)
+ fi
+- AC_MSG_CHECKING([whether db is at least 4.1])
+- for v in `seq 1 7`; do
+- AC_TRY_RUN([
+-#include <db.h>
+-
+-int main(int argc, char **argv) {
+- if(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR == $v) return 0;
+- else return 1;
+-}
+- ], [DB_VERSION_MINOR=$v], [])
+- done
+- if test "$DB_VERSION_MINOR" -gt "1"; then
+- AC_MSG_RESULT([OK])
+- DB_VERSION=4.$DB_VERSION_MINOR
+- else
+- AC_MSG_ERROR([no. you need at least db 4.1])
+- fi
+ save_LIBS="$LIBS"
+ for dbver in -4.8 4.8 -4.7 4.7 -4.6 4.6 -4.5 4.5 -4.4 4.4 -4.3 4.3 -4.2 4.2 -4.1 4.1 -4 4 ''; do
+ AC_CHECK_LIB(db$dbver, db_create, [ DB_LIB="db$dbver"; DB_CPPLIB="db_cxx$dbver"; LIBS="-ldb$dbver $LIBS"; break ])
+
diff --git a/app-office/openoffice/files/gentoo-3.1.1.diff b/app-office/openoffice/files/gentoo-3.1.1.diff
index 1dcbe8519c2f..2319b5faa34c 100644
--- a/app-office/openoffice/files/gentoo-3.1.1.diff
+++ b/app-office/openoffice/files/gentoo-3.1.1.diff
@@ -11,7 +11,7 @@
[ LinuxOnly ]
# fix that allows OOo to work with a standard (unpatched) libjpeg,
---- patches/dev300kde4-configure.diff
+--- patches/dev300/kde4-configure.diff
+++ patches/dev300/kde4-configure.diff
@@ -104,7 +104,7 @@
+MOC4="moc"
@@ -22,4 +22,24 @@
+
+ kde_incdirs="/usr/include $x_includes"
+ kde_libdirs="/usr/lib $x_libraries"
+--- patches/dev300/system-db-check.diff
++++ patches/dev300/system-db-check.diff
+@@ -12,7 +12,7 @@
+ - [ AC_MSG_ERROR(no. install the db4 libraries) ], []+ )
+ - ], []
+ - )
+-+ for dbver in -4.7 4.7 -4.6 4.6 -4.5 4.5 -4.4 4.4 -4.3 4.3 -4.2 4.2 -4.1 4.1 -4 4 ''; do
+++ for dbver in -4.8 4.8 -4.7 4.7 -4.6 4.6 -4.5 4.5 -4.4 4.4 -4.3 4.3 -4.2 4.2 -4.1 4.1 -4 4 ''; do
+ + AC_CHECK_HEADER(db$dbver/db.h, [ DB_INCLUDES="/usr/include/db$dbver"; break ])
+ + done
+ + if test "$DB_INCLUDES" = ""; then
+@@ -32,7 +32,7 @@
+ - [AC_MSG_ERROR([db not installed or functional])], [])
+ - SCPDEFS="$SCPDEFS -DSYSTEM_DB"
+ + save_LIBS="$LIBS"
+-+ for dbver in -4.7 4.7 -4.6 4.6 -4.5 4.5 -4.4 4.4 -4.3 4.3 -4.2 4.2 -4.1 4.1 -4 4 ''; do
+++ for dbver in -4.8 4.8 -4.7 4.7 -4.6 4.6 -4.5 4.5 -4.4 4.4 -4.3 4.3 -4.2 4.2 -4.1 4.1 -4 4 ''; do
+ + AC_CHECK_LIB(db$dbver, db_create, [ DB_LIB="db$dbver"; DB_CPPLIB="db_cxx$dbver"; LIBS="-ldb$dbver $LIBS"; break ])
+ + done
+ + AC_CHECK_FUNC(db_create, [], [ AC_MSG_ERROR([db not installed or functional]) ])