summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-23 11:34:32 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-23 11:34:32 +0000
commitcd4cb827ea7f67e85b668fec39a8449371af0b2d (patch)
treea4e5a6969d35a5c85d80d9c032a04df9b5a69f72 /app-office/libreoffice
parentfix #536778 by Thomas D. (diff)
downloadgentoo-2-cd4cb827ea7f67e85b668fec39a8449371af0b2d.tar.gz
gentoo-2-cd4cb827ea7f67e85b668fec39a8449371af0b2d.tar.bz2
gentoo-2-cd4cb827ea7f67e85b668fec39a8449371af0b2d.zip
Backport build fixes to 4.4.0
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 94BFDF4484AD142F)
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-4.4.0.3-gcc-4.9-Os-link-failure.patch80
-rw-r--r--app-office/libreoffice/libreoffice-4.4.0.3.ebuild10
3 files changed, 95 insertions, 2 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 07cfe7da99d2..171572e606e5 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.620 2015/02/22 22:38:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.621 2015/02/23 11:34:32 dilfridge Exp $
+
+ 23 Feb 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +files/libreoffice-4.4.0.3-gcc-4.9-Os-link-failure.patch,
+ libreoffice-4.4.0.3.ebuild:
+ Backport build fixes to 4.4.0
22 Feb 2015; Andreas K. Huettel <dilfridge@gentoo.org>
files/libreoffice-4.3.5.2-DPI.patch:
diff --git a/app-office/libreoffice/files/libreoffice-4.4.0.3-gcc-4.9-Os-link-failure.patch b/app-office/libreoffice/files/libreoffice-4.4.0.3-gcc-4.9-Os-link-failure.patch
new file mode 100644
index 000000000000..0f39688e5ea8
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-4.4.0.3-gcc-4.9-Os-link-failure.patch
@@ -0,0 +1,80 @@
+From 0e4b1d2127957459b79f41a96f1fa0061d399b3b Mon Sep 17 00:00:00 2001
+From: Michael Stahl <mstahl@redhat.com>
+Date: Sat, 14 Feb 2015 00:17:06 +0100
+Subject: tdf#78174: toolkit: work around GCC 4.9 -Os link failure
+
+A build with gcc (GCC) 4.9.2 20141101 (Red Hat 4.9.2-1) for 32-bit x86
+fails because of these undefined symbols:
+
+> nm --demangle workdir/CxxObject/svx/source/fmcomp/fmgridif.o | grep
+ \\bWindowListenerMultiplexer::acquire
+ U non-virtual thunk to WindowListenerMultiplexer::acquire()
+
+They should probably be generated inline. Work around by out-lining the
+definition of the methods.
+
+https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64812
+
+Change-Id: I318f7c39bdf1243be385bc6dc0a47862b22e92c5
+(cherry picked from commit 6b3aa0fe4094e87290bd33a30bd6cd99ee78ce38)
+Reviewed-on: https://gerrit.libreoffice.org/14509
+Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
+Tested-by: Miklos Vajna <vmiklos@collabora.co.uk>
+
+diff --git a/include/toolkit/helper/macros.hxx b/include/toolkit/helper/macros.hxx
+index e048e75..b212dff 100644
+--- a/include/toolkit/helper/macros.hxx
++++ b/include/toolkit/helper/macros.hxx
+@@ -112,8 +112,8 @@ class ClassName : public ListenerMultiplexerBase, public InterfaceName \
+ public: \
+ ClassName( ::cppu::OWeakObject& rSource ); \
+ ::com::sun::star::uno::Any SAL_CALL queryInterface( const ::com::sun::star::uno::Type & rType ) throw(::com::sun::star::uno::RuntimeException, std::exception) SAL_OVERRIDE; \
+- void SAL_CALL acquire() throw() SAL_OVERRIDE { ListenerMultiplexerBase::acquire(); } \
+- void SAL_CALL release() throw() SAL_OVERRIDE { ListenerMultiplexerBase::release(); } \
++ void SAL_CALL acquire() throw() SAL_OVERRIDE; \
++ void SAL_CALL release() throw() SAL_OVERRIDE; \
+ void SAL_CALL disposing( const ::com::sun::star::lang::EventObject& Source ) throw(::com::sun::star::uno::RuntimeException, std::exception) SAL_OVERRIDE;
+
+
+@@ -124,8 +124,8 @@ class TOOLKIT_DLLPUBLIC ClassName : public ListenerMultiplexerBase, public Inter
+ public: \
+ ClassName( ::cppu::OWeakObject& rSource ); \
+ ::com::sun::star::uno::Any SAL_CALL queryInterface( const ::com::sun::star::uno::Type & rType ) throw(::com::sun::star::uno::RuntimeException, std::exception) SAL_OVERRIDE; \
+- void SAL_CALL acquire() throw() SAL_OVERRIDE { ListenerMultiplexerBase::acquire(); } \
+- void SAL_CALL release() throw() SAL_OVERRIDE { ListenerMultiplexerBase::release(); } \
++ void SAL_CALL acquire() throw() SAL_OVERRIDE; \
++ void SAL_CALL release() throw() SAL_OVERRIDE; \
+ void SAL_CALL disposing( const ::com::sun::star::lang::EventObject& Source ) throw(::com::sun::star::uno::RuntimeException, std::exception) SAL_OVERRIDE;
+
+
+@@ -140,6 +140,8 @@ ClassName::ClassName( ::cppu::OWeakObject& rSource ) \
+ : ListenerMultiplexerBase( rSource ) \
+ { \
+ } \
++void SAL_CALL ClassName::acquire() throw() { ListenerMultiplexerBase::acquire(); } \
++void SAL_CALL ClassName::release() throw() { ListenerMultiplexerBase::release(); } \
+ ::com::sun::star::uno::Any ClassName::queryInterface( const ::com::sun::star::uno::Type & rType ) throw(::com::sun::star::uno::RuntimeException, std::exception) \
+ { \
+ ::com::sun::star::uno::Any aRet = ::cppu::queryInterface( rType, \
+diff --git a/toolkit/source/helper/listenermultiplexer.cxx b/toolkit/source/helper/listenermultiplexer.cxx
+index 797fad2..b109c5f 100644
+--- a/toolkit/source/helper/listenermultiplexer.cxx
++++ b/toolkit/source/helper/listenermultiplexer.cxx
+@@ -47,6 +47,15 @@ EventListenerMultiplexer::EventListenerMultiplexer( ::cppu::OWeakObject& rSource
+ {
+ }
+
++void SAL_CALL EventListenerMultiplexer::acquire() throw ()
++{
++ return ListenerMultiplexerBase::acquire();
++}
++void SAL_CALL EventListenerMultiplexer::release() throw ()
++{
++ return ListenerMultiplexerBase::release();
++}
++
+ // ::com::sun::star::uno::XInterface
+ ::com::sun::star::uno::Any EventListenerMultiplexer::queryInterface( const ::com::sun::star::uno::Type & rType ) throw(::com::sun::star::uno::RuntimeException, std::exception)
+ {
+--
+cgit v0.10.2
diff --git a/app-office/libreoffice/libreoffice-4.4.0.3.ebuild b/app-office/libreoffice/libreoffice-4.4.0.3.ebuild
index 83c227af8f44..d461ee3b5080 100644
--- a/app-office/libreoffice/libreoffice-4.4.0.3.ebuild
+++ b/app-office/libreoffice/libreoffice-4.4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.4.0.3.ebuild,v 1.3 2015/02/22 10:16:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.4.0.3.ebuild,v 1.4 2015/02/23 11:34:32 dilfridge Exp $
EAPI=5
@@ -244,6 +244,9 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-4.4-system-pyuno.patch"
+ # from 4.4 branch
+ "${FILESDIR}/${PN}-4.4.0.3-gcc-4.9-Os-link-failure.patch" # bug 538348
+
# from master branch
"${FILESDIR}/${PN}-4.4.0.3-telepathy-build-fix.patch"
)
@@ -524,6 +527,11 @@ src_configure() {
}
src_compile() {
+ # more and more LO stuff tries to use OpenGL, including tests during build
+ # bug 501508, bug 540624 and probably more
+ addpredict /dev/dri
+ addpredict /dev/nvidiactl
+
# hack for offlinehelp, this needs fixing upstream at some point
# it is broken because we send --without-help
# https://bugs.freedesktop.org/show_bug.cgi?id=46506