summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-08 22:42:18 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-02-08 22:42:18 +0000
commitdec11c89dd6d529e0cd7b40452afa0ed462adb44 (patch)
treef658a72eab562c738625d235d72dbb2f9e39d39e /app-office/libreoffice/libreoffice-4.3.9999.ebuild
parentStable on amd64, ppc, ppc64 and x86 (diff)
downloadgentoo-2-dec11c89dd6d529e0cd7b40452afa0ed462adb44.tar.gz
gentoo-2-dec11c89dd6d529e0cd7b40452afa0ed462adb44.tar.bz2
gentoo-2-dec11c89dd6d529e0cd7b40452afa0ed462adb44.zip
Version bump (without keywords so far); update live ebuilds to git-r3.eclass; backport DPI patch for bug 523822 to the 4.3 branch. Thanks to Andreas Sturmlechner.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office/libreoffice/libreoffice-4.3.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-4.3.9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-office/libreoffice/libreoffice-4.3.9999.ebuild b/app-office/libreoffice/libreoffice-4.3.9999.ebuild
index 761f70ab641e..5897b0ac82d7 100644
--- a/app-office/libreoffice/libreoffice-4.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-4.3.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.9999.ebuild,v 1.12 2015/02/08 18:53:59 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.3.9999.ebuild,v 1.13 2015/02/08 22:42:18 dilfridge Exp $
EAPI=5
@@ -26,7 +26,7 @@ ADDONS_URI="http://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
-[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
+[[ ${PV} == *9999* ]] && SCM_ECLASS="git-r3"
inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
unset SCM_ECLASS
@@ -252,6 +252,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.3.4.1-boost-1.56.0.patch" # bug 522178
"${FILESDIR}/${PN}-4.3.5.2-system-opencollada.patch"
"${FILESDIR}/${PN}-4.3.5.2-detect-KDE5-fallback-to-KDE4UI.patch"
+ "${FILESDIR}/${PN}-4.3.5.2-DPI.patch"
# from master branch
@@ -325,12 +326,10 @@ src_unpack() {
for mod in ${MODULES}; do
mypv=${PV/.9999}
[[ ${mypv} != ${PV} ]] && EGIT_BRANCH="${PN}-${mypv/./-}"
- EGIT_PROJECT="${PN}/${mod}"
- EGIT_SOURCEDIR="${WORKDIR}/${P}"
- [[ ${mod} != core ]] && EGIT_SOURCEDIR="${WORKDIR}/${PN}-${mod}-${PV}"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+ [[ ${mod} != core ]] && EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}-${mod}-${PV}"
EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}/${mod}"
- EGIT_NOUNPACK="true"
- git-2_src_unpack
+ git-r3_src_unpack
if [[ ${mod} != core ]]; then
mod2=${mod}
# mapping does not match on help
@@ -340,7 +339,7 @@ src_unpack() {
rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
fi
done
- unset EGIT_PROJECT EGIT_SOURCEDIR EGIT_REPO_URI EGIT_BRANCH
+ unset EGIT_CHECKOUT_DIR EGIT_REPO_URI EGIT_BRANCH
fi
}