summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-19 18:27:03 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-19 18:27:03 +0000
commitd86fa2e041ac156f9c8779d40886631a4e14fd67 (patch)
treeddd57818724bc370d59948f07a7cc5d28d5226b9 /app-office/libalkimia
parentinitial import of rb-readline from pentoo repo (diff)
downloadgentoo-2-d86fa2e041ac156f9c8779d40886631a4e14fd67.tar.gz
gentoo-2-d86fa2e041ac156f9c8779d40886631a4e14fd67.tar.bz2
gentoo-2-d86fa2e041ac156f9c8779d40886631a4e14fd67.zip
Revision bump to EAPI 5.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-office/libalkimia')
-rw-r--r--app-office/libalkimia/ChangeLog10
-rw-r--r--app-office/libalkimia/libalkimia-4.3.2-r1.ebuild28
2 files changed, 35 insertions, 3 deletions
diff --git a/app-office/libalkimia/ChangeLog b/app-office/libalkimia/ChangeLog
index 74cbb8d177a2..fb3aeb7885a2 100644
--- a/app-office/libalkimia/ChangeLog
+++ b/app-office/libalkimia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libalkimia
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libalkimia/ChangeLog,v 1.12 2012/05/03 20:00:40 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libalkimia/ChangeLog,v 1.13 2014/03/19 18:27:03 johu Exp $
+
+*libalkimia-4.3.2-r1 (19 Mar 2014)
+
+ 19 Mar 2014; Johannes Huber <johu@gentoo.org> +libalkimia-4.3.2-r1.ebuild:
+ Revision bump to EAPI 5.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> libalkimia-4.3.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -52,4 +57,3 @@
+libalkimia-4.3.0.ebuild, +files/libalkimia-4.3.0-doc.patch,
+metadata.xml:
New library
-
diff --git a/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild b/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..bc90e99a256c
--- /dev/null
+++ b/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libalkimia/libalkimia-4.3.2-r1.ebuild,v 1.1 2014/03/19 18:27:03 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
+HOMEPAGE="http://kde-apps.org/content/show.php/libalkimia?content=137323"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/137323-${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${PN}-4.3.2-doc.patch" )
+
+src_configure() {
+ mycmakeargs=( $(cmake-utils_use_build doc) )
+ kde4-base_src_configure
+}