summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:29:50 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:29:50 +0000
commitf3d541d283a5a657ab83460813da7325565bf4bc (patch)
treeacb5f34c2b6ee4acdaa0a9b5a7a4e2056875931f /app-office/kword
parentVersion bump. (diff)
downloadgentoo-2-f3d541d283a5a657ab83460813da7325565bf4bc.tar.gz
gentoo-2-f3d541d283a5a657ab83460813da7325565bf4bc.tar.bz2
gentoo-2-f3d541d283a5a657ab83460813da7325565bf4bc.zip
Version bump.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/files/digest-kword-1.6_rc13
-rw-r--r--app-office/kword/kword-1.6_rc1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 78e6849619d8..ca77b350e98f 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.68 2006/09/19 10:15:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.69 2006/09/27 23:29:50 carlo Exp $
+
+*kword-1.6_rc1 (27 Sep 2006)
+
+ 27 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +kword-1.6_rc1.ebuild:
+ Version bump.
19 Sep 2006; Markus Rothe <corsair@gentoo.org> kword-1.4.2-r7.ebuild:
Stable on ppc64; bug #146409
diff --git a/app-office/kword/files/digest-kword-1.6_rc1 b/app-office/kword/files/digest-kword-1.6_rc1
new file mode 100644
index 000000000000..22dfd6c9ed05
--- /dev/null
+++ b/app-office/kword/files/digest-kword-1.6_rc1
@@ -0,0 +1,3 @@
+MD5 2134a0d09a3f98b91a062c7bafb57622 koffice-1.5.92.tar.bz2 54676447
+RMD160 4006772a542c24132ef7b7d16ad087beb6eb76cd koffice-1.5.92.tar.bz2 54676447
+SHA256 a4df08decea688dddfeec7b47e0fb4e96bf75e1c85b72b721d315d718bae11c5 koffice-1.5.92.tar.bz2 54676447
diff --git a/app-office/kword/kword-1.6_rc1.ebuild b/app-office/kword/kword-1.6_rc1.ebuild
new file mode 100644
index 000000000000..7f5bdcc05feb
--- /dev/null
+++ b/app-office/kword/kword-1.6_rc1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6_rc1.ebuild,v 1.1 2006/09/27 23:29:50 carlo Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}