summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-08-12 10:01:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-08-12 10:01:34 +0000
commit3c8408e3b7a7e94ead16da93b00b7085809d5893 (patch)
tree2bc13aabbd2357657b9ffd0b4e9180360d49421a /app-office/kword
parentKOFFICE: Version bump to 2.0.2. (diff)
downloadgentoo-2-3c8408e3b7a7e94ead16da93b00b7085809d5893.tar.gz
gentoo-2-3c8408e3b7a7e94ead16da93b00b7085809d5893.tar.bz2
gentoo-2-3c8408e3b7a7e94ead16da93b00b7085809d5893.zip
KOFFICE: Version bump to 2.0.2.
(Portage version: 2.2_rc33/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/kword-2.0.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 4f409cacda34..849c464f87de 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.129 2009/07/23 14:12:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.130 2009/08/12 10:01:34 scarabeus Exp $
+
+*kword-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +kword-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kword-1.6.3_p20090204.ebuild:
diff --git a/app-office/kword/kword-2.0.2.ebuild b/app-office/kword/kword-2.0.2.ebuild
new file mode 100644
index 000000000000..93c8c58e4775
--- /dev/null
+++ b/app-office/kword/kword-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.0.2.ebuild,v 1.1 2009/08/12 10:01:34 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+wpd +wv2"
+
+DEPEND="
+ app-text/libwpd
+ app-text/wv2
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}/"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpd WPD)
+ $(cmake-utils_use_with wv2 WV2)"
+
+ kde4-meta_src_configure
+}