summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:24:30 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-08 17:24:30 +0000
commit7ece8bab9f38532e66f20256acec528bc7eaefc2 (patch)
treeedae16b53c00952578c613a5bd6ac96b30fb5b82 /app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild
parentamd64/x86 stable, bug #245852 (diff)
downloadgentoo-2-7ece8bab9f38532e66f20256acec528bc7eaefc2.tar.gz
gentoo-2-7ece8bab9f38532e66f20256acec528bc7eaefc2.tar.bz2
gentoo-2-7ece8bab9f38532e66f20256acec528bc7eaefc2.zip
Sync to branch plus various fixes.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild')
-rw-r--r--app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild b/app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild
new file mode 100644
index 000000000000..a0555412a92b
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-1.6.3_p20090204.ebuild,v 1.1 2009/02/08 17:24:30 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+KMNAME=koffice
+KMMODULE=lib
+inherit kde-meta eutils
+
+DESCRIPTION="Shared KOffice libraries."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="~app-office/koffice-data-1.6.3_p20090204
+ virtual/python
+ dev-lang/ruby"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+KMEXTRA="interfaces/
+ plugins/
+ tools/
+ filters/olefilters/
+ filters/xsltfilter/
+ filters/generic_wrapper/
+ kounavail/
+ doc/api/
+ doc/koffice/
+ doc/thesaurus/"
+
+KMEXTRACTONLY="
+ kchart/kdchart/"
+
+need-kde 3.5
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # Force the compilation of libkopainter.
+ sed -i 's:$(KOPAINTERDIR):kopainter:' "${S}/lib/Makefile.am"
+
+ if ! [[ $(xhost >> /dev/null 2>/dev/null) ]] ; then
+ einfo "User ${USER} has no X access, disabling some tests."
+ sed -e "s:SUBDIRS = . tests:SUBDIRS = .:" -i lib/store/Makefile.am || die "sed failed"
+ sed -e "s:SUBDIRS = kohyphen . tests:SUBDIRS = kohyphen .:" -i lib/kotext/Makefile.am || die "sed failed"
+ fi
+
+ kde-meta_src_unpack makefiles
+}
+
+src_compile() {
+ local myconf="--enable-scripting --with-pythonfir=/usr/$(get_libdir)/python${PYVER}/site-packages"
+ kde-meta_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde-meta_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+}