summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:49:54 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:49:54 +0000
commit9c1c9563f432427dbc6f18936d5a911819d3e464 (patch)
tree4b3d534146d17152cec8e3d0344c77edda0ffb13 /app-office/koffice-l10n
parentVersion bump (diff)
downloadgentoo-2-9c1c9563f432427dbc6f18936d5a911819d3e464.tar.gz
gentoo-2-9c1c9563f432427dbc6f18936d5a911819d3e464.tar.bz2
gentoo-2-9c1c9563f432427dbc6f18936d5a911819d3e464.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office/koffice-l10n')
-rw-r--r--app-office/koffice-l10n/ChangeLog8
-rw-r--r--app-office/koffice-l10n/koffice-l10n-2.2.2.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/app-office/koffice-l10n/ChangeLog b/app-office/koffice-l10n/ChangeLog
index 293a53f20349..9db569982eef 100644
--- a/app-office/koffice-l10n/ChangeLog
+++ b/app-office/koffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-l10n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.15 2010/04/01 20:22:28 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.16 2010/09/25 20:49:54 dilfridge Exp $
+
+*koffice-l10n-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +koffice-l10n-2.2.2.ebuild:
+ Version bump
*koffice-l10n-2.1.2 (01 Apr 2010)
diff --git a/app-office/koffice-l10n/koffice-l10n-2.2.2.ebuild b/app-office/koffice-l10n/koffice-l10n-2.2.2.ebuild
new file mode 100644
index 000000000000..95ca1a5cc6b9
--- /dev/null
+++ b/app-office/koffice-l10n/koffice-l10n-2.2.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/koffice-l10n-2.2.2.ebuild,v 1.1 2010/09/25 20:49:54 dilfridge Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KOffice localization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca da de el en_GB es et fr gl it ja kk nb nds nl pl pt pt_BR
+ ru sv tr uk wa zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/koffice-${PV}/${PN}/"
+SRC_URI=""
+SLOT="2"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs} -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)"
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}