summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-04-01 20:22:28 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-04-01 20:22:28 +0000
commit740a84dd4c329e207f73d03832086932923197eb (patch)
tree349e80c3cb52318b88988662ea216fdff691d006 /app-office/koffice-l10n
parentStop build downloading deps #312175. (diff)
downloadgentoo-2-740a84dd4c329e207f73d03832086932923197eb.tar.gz
gentoo-2-740a84dd4c329e207f73d03832086932923197eb.tar.bz2
gentoo-2-740a84dd4c329e207f73d03832086932923197eb.zip
add koffice 2.1.2 l10n
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office/koffice-l10n')
-rw-r--r--app-office/koffice-l10n/ChangeLog8
-rw-r--r--app-office/koffice-l10n/koffice-l10n-2.1.2.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/app-office/koffice-l10n/ChangeLog b/app-office/koffice-l10n/ChangeLog
index 3661f88ff6cc..293a53f20349 100644
--- a/app-office/koffice-l10n/ChangeLog
+++ b/app-office/koffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-l10n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.14 2010/02/27 22:35:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.15 2010/04/01 20:22:28 tampakrap Exp $
+
+*koffice-l10n-2.1.2 (01 Apr 2010)
+
+ 01 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +koffice-l10n-2.1.2.ebuild:
+ add koffice 2.1.2 l10n
*koffice-l10n-2.1.1 (27 Feb 2010)
diff --git a/app-office/koffice-l10n/koffice-l10n-2.1.2.ebuild b/app-office/koffice-l10n/koffice-l10n-2.1.2.ebuild
new file mode 100644
index 000000000000..7e3d35dfb404
--- /dev/null
+++ b/app-office/koffice-l10n/koffice-l10n-2.1.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/koffice-l10n-2.1.2.ebuild,v 1.1 2010/04/01 20:22:28 tampakrap Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca da de el en_GB es et fr fy gl hne it ja kk nb nds nl pl pt pt_BR
+ sv tr uk wa zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/koffice-${PV}/${PN}/"
+SRC_URI=""
+SLOT="2"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs} -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)"
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}