summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:48:21 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:48:21 +0000
commita4626061c33fac74465cd9280baa901f795cdc89 (patch)
tree69e54ade74713d9ada08154c2a321837e99508cd /app-office/kexi
parentVersion bump. (diff)
downloadgentoo-2-a4626061c33fac74465cd9280baa901f795cdc89.tar.gz
gentoo-2-a4626061c33fac74465cd9280baa901f795cdc89.tar.bz2
gentoo-2-a4626061c33fac74465cd9280baa901f795cdc89.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/files/digest-kexi-1.6_beta13
-rw-r--r--app-office/kexi/kexi-1.6_beta1.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index ee023aa6e205..5066869ca565 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.44 2006/09/07 14:11:11 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.45 2006/09/15 18:48:21 carlo Exp $
+
+*kexi-1.6_beta1 (15 Sep 2006)
+
+ 15 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +kexi-1.6_beta1.ebuild:
+ Version bump.
07 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> kexi-1.5.1.ebuild:
Stable on sparc
diff --git a/app-office/kexi/files/digest-kexi-1.6_beta1 b/app-office/kexi/files/digest-kexi-1.6_beta1
new file mode 100644
index 000000000000..a68717744650
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.6_beta1
@@ -0,0 +1,3 @@
+MD5 c7aeaf362210ff2e52d610bdbe2c91fd koffice-1.5.91.tar.bz2 54138646
+RMD160 8b412a4d6199cec32fd4a43660abb1352d675dd4 koffice-1.5.91.tar.bz2 54138646
+SHA256 2e1cbd20c8201a9d2d4c14fa4184b112d90a8f8bb089915f4d748eb9f8cef7aa koffice-1.5.91.tar.bz2 54138646
diff --git a/app-office/kexi/kexi-1.6_beta1.ebuild b/app-office/kexi/kexi-1.6_beta1.ebuild
new file mode 100644
index 000000000000..a257c1a53e98
--- /dev/null
+++ b/app-office/kexi/kexi-1.6_beta1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6_beta1.ebuild,v 1.1 2006/09/15 18:48:21 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ kde-meta_src_compile
+}