summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-03-29 15:15:24 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-03-29 15:15:24 +0000
commita4ec8ce3b08eb069f691be3897e799be31958abd (patch)
tree89656c5e1e7eeb936cfe90e0111a9382d4923c7a /app-office/karbon
parentVersion bump. (diff)
downloadgentoo-2-a4ec8ce3b08eb069f691be3897e799be31958abd.tar.gz
gentoo-2-a4ec8ce3b08eb069f691be3897e799be31958abd.tar.bz2
gentoo-2-a4ec8ce3b08eb069f691be3897e799be31958abd.zip
Version bump.
(Portage version: 2.0.54)
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/Manifest4
-rw-r--r--app-office/karbon/files/digest-karbon-1.5_rc11
-rw-r--r--app-office/karbon/karbon-1.5_rc1.ebuild52
4 files changed, 62 insertions, 2 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index c31e9131db47..3ed5b7756185 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.30 2006/03/11 15:55:07 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.31 2006/03/29 15:15:24 carlo Exp $
+
+*karbon-1.5_rc1 (29 Mar 2006)
+
+ 29 Mar 2006; Carsten Lohrke <carlo@gentoo.org> +karbon-1.5_rc1.ebuild:
+ Version bump.
*karbon-1.5_beta2 (11 Mar 2006)
diff --git a/app-office/karbon/Manifest b/app-office/karbon/Manifest
index e679add7cdee..6ca2b4379e51 100644
--- a/app-office/karbon/Manifest
+++ b/app-office/karbon/Manifest
@@ -1,8 +1,10 @@
-MD5 760d189d6ae6f7e806955433efd39983 ChangeLog 3329
+MD5 cef6bc0b8bcf386b5d4e16634bc12bc8 ChangeLog 3450
MD5 902823ac54984271d00a3e72454440b1 files/digest-karbon-1.4.2 250
MD5 82af01b67d83c02945f1e26ae9529232 files/digest-karbon-1.5_beta1 253
MD5 a08e04910037e4b3b9e9cbfb92eda61e files/digest-karbon-1.5_beta2 69
+MD5 f01ddda79b7e0afa602b27c09ae05217 files/digest-karbon-1.5_rc1 72
MD5 420ed53c8e73ffa9d45e25d2904f7610 karbon-1.4.2.ebuild 1180
MD5 42a51c7d47ecf144e20577a93e9a3fd2 karbon-1.5_beta1.ebuild 1172
MD5 efbad1797c68557aaac215defa603b88 karbon-1.5_beta2.ebuild 1172
+MD5 42a51c7d47ecf144e20577a93e9a3fd2 karbon-1.5_rc1.ebuild 1172
MD5 02039d51ca4a42817775fd436dfaa956 metadata.xml 157
diff --git a/app-office/karbon/files/digest-karbon-1.5_rc1 b/app-office/karbon/files/digest-karbon-1.5_rc1
new file mode 100644
index 000000000000..cf4d6b4f0ae2
--- /dev/null
+++ b/app-office/karbon/files/digest-karbon-1.5_rc1
@@ -0,0 +1 @@
+MD5 e9346977d18c67185d5b50f49ee8225b koffice-1.5.0-rc1.tar.bz2 35965316
diff --git a/app-office/karbon/karbon-1.5_rc1.ebuild b/app-office/karbon/karbon-1.5_rc1.ebuild
new file mode 100644
index 000000000000..0bd24ddaa5c4
--- /dev/null
+++ b/app-office/karbon/karbon-1.5_rc1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.5_rc1.ebuild,v 1.1 2006/03/29 15:15:24 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkopalette lib/kopalette
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}