summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-19 05:44:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-19 05:44:16 +0000
commit8572c075cceb5d89005ec9a755f3976a42d25b0d (patch)
tree43993f457b76e85f19dcb3e0b356572da5738190 /app-office/ical
parentUpdated CVS snapshot (Manifest recommit) (diff)
downloadgentoo-2-8572c075cceb5d89005ec9a755f3976a42d25b0d.tar.gz
gentoo-2-8572c075cceb5d89005ec9a755f3976a42d25b0d.tar.bz2
gentoo-2-8572c075cceb5d89005ec9a755f3976a42d25b0d.zip
IUSE; error check sed; tidy
Diffstat (limited to 'app-office/ical')
-rw-r--r--app-office/ical/ChangeLog5
-rw-r--r--app-office/ical/ical-2.2.1.ebuild11
2 files changed, 11 insertions, 5 deletions
diff --git a/app-office/ical/ChangeLog b/app-office/ical/ChangeLog
index 175a3c43d892..df65c1e1a80d 100644
--- a/app-office/ical/ChangeLog
+++ b/app-office/ical/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/ical
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.7 2004/06/06 20:07:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.8 2004/06/19 05:44:16 mr_bones_ Exp $
+
+ 18 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> ical-2.2.1.ebuild:
+ IUSE; error check sed; tidy
06 Jun 2004; Seemant Kulleen <seemant@gentoo.org> ical-2.2.1.ebuild:
Fix compile error reported by Daniel Webert <daniel_webert@web.de> in bug
diff --git a/app-office/ical/ical-2.2.1.ebuild b/app-office/ical/ical-2.2.1.ebuild
index dae80b2d7e03..db2bd38eaf2c 100644
--- a/app-office/ical/ical-2.2.1.ebuild
+++ b/app-office/ical/ical-2.2.1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.8 2004/06/06 20:07:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.9 2004/06/19 05:44:16 mr_bones_ Exp $
inherit eutils
PATCH_VER="0.1"
MY_P=${P}a
-S=${WORKDIR}/${MY_P}
DESCRIPTION="Tk-based Calendar program"
HOMEPAGE="http://www.fnal.gov/docs/products/tktools/ical.html"
SRC_URI="http://helios.dii.utk.edu/ftp/pub/tcl/apps/ical/${MY_P}.tar.bz2
@@ -15,6 +14,7 @@ SRC_URI="http://helios.dii.utk.edu/ftp/pub/tcl/apps/ical/${MY_P}.tar.bz2
LICENSE="as-is GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
RDEPEND="dev-lang/tcl
dev-lang/tk"
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
>=sys-apps/sed-4
sys-devel/autoconf"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
@@ -34,7 +36,8 @@ src_unpack() {
sed -i \
-e "s: \@TCL_LIBS\@::" \
-e "s:mkdir:mkdir -p:" \
- ${S}/Makefile.in
+ ${S}/Makefile.in \
+ || die "sed Makefile.in failed"
has_version '=dev-lang/tcl-8.4*' && epatch ${MY_P}-tcl8.4.patch
}
@@ -47,5 +50,5 @@ src_compile() {
src_install() {
einstall \
- MANDIR=${D}/usr/share/man || die "install failed"
+ MANDIR="${D}/usr/share/man" || die "install failed"
}