summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-30 19:39:29 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-30 19:39:29 +0000
commit2800f9c78e03261e4f5be52c0bd0da6246fd0c7a (patch)
treef2b2422ff6534786300efba66d33b2534f28182c /app-office/ical
parentInvalid entry, there's no X.org server 1.4 in tree anymore. (diff)
downloadgentoo-2-2800f9c78e03261e4f5be52c0bd0da6246fd0c7a.tar.gz
gentoo-2-2800f9c78e03261e4f5be52c0bd0da6246fd0c7a.tar.bz2
gentoo-2-2800f9c78e03261e4f5be52c0bd0da6246fd0c7a.zip
Added patch allowing compilation against glibc-2.10, closes bug #274307, Respecting CC variable
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-office/ical')
-rw-r--r--app-office/ical/ChangeLog9
-rw-r--r--app-office/ical/files/ical-2.3.3-glibc210.patch16
-rw-r--r--app-office/ical/ical-2.2.1.ebuild9
-rw-r--r--app-office/ical/ical-2.3.3.ebuild6
4 files changed, 31 insertions, 9 deletions
diff --git a/app-office/ical/ChangeLog b/app-office/ical/ChangeLog
index ff35ef377c08..1155aefecaed 100644
--- a/app-office/ical/ChangeLog
+++ b/app-office/ical/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/ical
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.19 2009/01/21 16:28:32 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.20 2009/07/30 19:39:29 vostorga Exp $
+
+ 30 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> ical-2.2.1.ebuild,
+ ical-2.3.3.ebuild, +files/ical-2.3.3-glibc210.patch:
+ Added patch allowing compilation against glibc-2.10, closes bug #274307
+ Respecting CC variable.
17 Jan 2009; Federico Ferri <mescalinum@gentoo.org> ChangeLog:
closes bug #158621
diff --git a/app-office/ical/files/ical-2.3.3-glibc210.patch b/app-office/ical/files/ical-2.3.3-glibc210.patch
new file mode 100644
index 000000000000..d57c916695f8
--- /dev/null
+++ b/app-office/ical/files/ical-2.3.3-glibc210.patch
@@ -0,0 +1,16 @@
+diff -NrU5 ical-2.3.3.original/calendar/calfile.C ical-2.3.3/calendar/calfile.C
+--- ical-2.3.3.original/calendar/calfile.C 2009-07-30 15:06:53.000000000 +0000
++++ ical-2.3.3/calendar/calfile.C 2009-07-30 15:10:14.000000000 +0000
+@@ -56,11 +56,11 @@
+ tmp = new char[len+2];
+ sprintf(tmp, "%s~", fileName);
+ backupName = tmp;
+
+ // Get directory name for access checks
+- char* lastSlash = strrchr(name, '/');
++ const char* lastSlash = strrchr(name, '/');
+ if (lastSlash == 0) {
+ /* Calendar is in current directory */
+ tmp = new char[3];
+ strcpy(tmp, "./");
+ }
diff --git a/app-office/ical/ical-2.2.1.ebuild b/app-office/ical/ical-2.2.1.ebuild
index ebf0e7ed6844..be0607696bf3 100644
--- a/app-office/ical/ical-2.2.1.ebuild
+++ b/app-office/ical/ical-2.2.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.16 2006/04/08 09:14:09 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.17 2009/07/30 19:39:29 vostorga Exp $
inherit eutils
-PATCH_VER="0.1"
+PATCH_VER="0.2"
MY_P="${P}a"
DESCRIPTION="Tk-based Calendar program"
HOMEPAGE="http://www.fnal.gov/docs/products/tktools/ical.html"
@@ -32,6 +32,7 @@ src_unpack() {
epatch ${MY_P}-hack.patch
epatch ${MY_P}-glibc22.patch
epatch ${MY_P}-print.patch
+ epatch ${MY_P}-glibc210.patch
sed -i \
-e "s: \@TCL_LIBS\@::" \
@@ -46,7 +47,7 @@ src_compile() {
# don't use autoconf, bug 101658
# autoconf
econf --with-tclsh=/usr/bin/tclsh || die
- emake -j1 || die "make failed"
+ emake CXX=$(tc-getCXX) -j1 || die "make failed"
}
src_install() {
diff --git a/app-office/ical/ical-2.3.3.ebuild b/app-office/ical/ical-2.3.3.ebuild
index ca9531d87ae7..260ce33ce48a 100644
--- a/app-office/ical/ical-2.3.3.ebuild
+++ b/app-office/ical/ical-2.3.3.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.3.3.ebuild,v 1.1 2009/01/17 02:25:28 mescalinum Exp $
-
-WANT_AUTOCONF=latest
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.3.3.ebuild,v 1.2 2009/07/30 19:39:29 vostorga Exp $
inherit autotools eutils multilib
@@ -18,6 +16,7 @@ RESTRICT="test"
DEPEND="dev-lang/tcl
dev-lang/tk"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
@@ -30,6 +29,7 @@ src_unpack() {
Makefile.in || die
epatch "${FILESDIR}"/${P}-tcl8.5.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
eautoconf
cd "${S}/types"; eautoconf
}