summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 23:25:23 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 23:25:23 +0000
commit2cc5cc64a54d44077ad9c97c0067becef1dc533b (patch)
tree25e3d49b0cde02190dd3fffe425d4c06caae1823 /app-office/gnumeric
parentget it to compile with gcc (diff)
downloadgentoo-2-2cc5cc64a54d44077ad9c97c0067becef1dc533b.tar.gz
gentoo-2-2cc5cc64a54d44077ad9c97c0067becef1dc533b.tar.bz2
gentoo-2-2cc5cc64a54d44077ad9c97c0067becef1dc533b.zip
Changed econf||die to econf
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/gnumeric-1.1.8.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/app-office/gnumeric/gnumeric-1.1.8.ebuild b/app-office/gnumeric/gnumeric-1.1.8.ebuild
index 347c7ab147e4..052f85700e0c 100644
--- a/app-office/gnumeric/gnumeric-1.1.8.ebuild
+++ b/app-office/gnumeric/gnumeric-1.1.8.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.8.ebuild,v 1.3 2002/10/05 05:39:09 drobbins Exp $
-
-IUSE="nls libgda gb evo python guile perl"
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.8.ebuild,v 1.4 2002/11/30 23:25:23 vapier Exp $
#provide Xmake and Xemake
inherit virtualx libtool
-S=${WORKDIR}/${P}
DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
SRC_URI="ftp://ftp.gnome.org/pub/gnome/unstable/sources/${PN}/${P}.tar.bz2"
HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
@@ -15,6 +12,7 @@ HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="nls libgda gb evo python guile perl"
#Eye Of Gnome (media-gfx/eog) is for image support.
RDEPEND="=x11-libs/gtk+-2.0*
@@ -35,12 +33,10 @@ RDEPEND="=x11-libs/gtk+-2.0*
libgda? ( >=gnome-extra/libgda-0.2.91
>=gnome-base/bonobo-1.0.17 )
evo? ( >=net-mail/evolution-1.0.8 )"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext
>=dev-util/intltool-0.11 )"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -69,7 +65,7 @@ src_compile() {
&& myconf="${myconf} --with-python" \
|| myconf="${myconf} --without-python"
- econf ${myconf} || die
+ econf ${myconf}
#'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
#else the build fails.
@@ -77,7 +73,7 @@ src_compile() {
#the build process have to be able to connect to X
Xemake || Xmake || die
-}
+}
src_install() {
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
@@ -92,7 +88,7 @@ pkg_postinst() {
echo ">>> updating GConf2 (modemlights)"
for SCHEMA in gnumeric-dialogs.schemas gnumeric-general.schemas ; do
echo $SCHEMA
- /usr/bin/gconftool-2 --makefile-install-rule \
+ /usr/bin/gconftool-2 --makefile-install-rule \
/etc/gconf/schemas/${SCHEMA}
done
}