summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-29 18:42:54 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-29 18:42:54 +0000
commit6d614944914a37a7fd11e62954a307ebbb45f7fb (patch)
tree76d29fd446f634c6a7afa864e307b71eddb5ac6c /app-office/gnucash
parent*** empty log message *** (diff)
downloadgentoo-2-6d614944914a37a7fd11e62954a307ebbb45f7fb.tar.gz
gentoo-2-6d614944914a37a7fd11e62954a307ebbb45f7fb.tar.bz2
gentoo-2-6d614944914a37a7fd11e62954a307ebbb45f7fb.zip
Missing files
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/gnucash-1.4.7-r2.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-office/gnucash/gnucash-1.4.7-r2.ebuild b/app-office/gnucash/gnucash-1.4.7-r2.ebuild
index c6177c5b6827..7e110d6dbb20 100644
--- a/app-office/gnucash/gnucash-1.4.7-r2.ebuild
+++ b/app-office/gnucash/gnucash-1.4.7-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.4.7-r2.ebuild,v 1.3 2000/11/27 22:48:59 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.4.7-r2.ebuild,v 1.4 2001/04/29 18:42:54 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,21 +11,27 @@ HOMEPAGE="http://gnucash.sourceforge.net"
DEPEND=">=gnome-base/gnome-libs-1.2.4
>=gnome-base/libxml-1.8.10
+ >=sys-devel/perl-4
>=dev-lang/swig-1.3_alpha4
- >=dev-libs/slib-2.3.8"
+ >=dev-libs/slib-2.3.8
+ nls? ( sys-devel/gettext )"
src_compile() {
- cd ${S}
- try ./configure --prefix=/opt/gnome --host=${CHOST} --with-catgets
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/opt/gnome --host=${CHOST} $myconf
try make
}
src_install () {
- cd ${S}
try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS REDAME TODO
+
}