summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-06 23:03:29 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-06 23:03:29 +0000
commitd1d75df0fc6d3c6e97a61269a3496833ef6b204f (patch)
treea2608bdb3ae7e4ffabd10618fbfc8d47edea71ec /app-office/calligra-l10n
parentCleanup live ebuild (diff)
downloadgentoo-2-d1d75df0fc6d3c6e97a61269a3496833ef6b204f.tar.gz
gentoo-2-d1d75df0fc6d3c6e97a61269a3496833ef6b204f.tar.bz2
gentoo-2-d1d75df0fc6d3c6e97a61269a3496833ef6b204f.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-office/calligra-l10n')
-rw-r--r--app-office/calligra-l10n/ChangeLog7
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.6.4.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/app-office/calligra-l10n/ChangeLog b/app-office/calligra-l10n/ChangeLog
index d1edabc221cb..8ae72eb6a04d 100644
--- a/app-office/calligra-l10n/ChangeLog
+++ b/app-office/calligra-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calligra-l10n
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.35 2013/06/05 19:39:50 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/ChangeLog,v 1.36 2013/06/06 23:03:29 johu Exp $
+
+*calligra-l10n-2.6.4 (06 Jun 2013)
+
+ 06 Jun 2013; Johannes Huber <johu@gentoo.org> +calligra-l10n-2.6.4.ebuild:
+ Version bump.
05 Jun 2013; Johannes Huber <johu@gentoo.org> -calligra-l10n-2.5.3.ebuild:
Remove old.
diff --git a/app-office/calligra-l10n/calligra-l10n-2.6.4.ebuild b/app-office/calligra-l10n/calligra-l10n-2.6.4.ebuild
new file mode 100644
index 000000000000..91a21d657dbd
--- /dev/null
+++ b/app-office/calligra-l10n/calligra-l10n-2.6.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calligra-l10n/calligra-l10n-2.6.4.ebuild,v 1.1 2013/06/06 23:03:29 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Calligra localization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="!app-office/koffice-l10n"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+MY_LANGS="bs ca cs da de el en_GB es et fi fr gl hu it kk nb nds nl pl pt pt_BR
+ru sk sl sv tr uk zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/${PN/-l10n/}-${PV}/${PN}/"
+SRC_URI=""
+SLOT="4"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+unset MY_LANG
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)
+ )
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}