summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-17 20:41:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-17 20:41:51 +0000
commit2b9288efa7bc456c4aa4eb22b2d27dbdc2c922e8 (patch)
treecd9bdba19b8627568852d101c404cbd8d1ea2714 /app-office/abiword
parentarm stable, bug #476364 (diff)
downloadgentoo-2-2b9288efa7bc456c4aa4eb22b2d27dbdc2c922e8.tar.gz
gentoo-2-2b9288efa7bc456c4aa4eb22b2d27dbdc2c922e8.tar.bz2
gentoo-2-2b9288efa7bc456c4aa4eb22b2d27dbdc2c922e8.zip
Apply upstream fix to solve abiword-docs building in the right way
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog8
-rw-r--r--app-office/abiword/abiword-3.0.0-r1.ebuild (renamed from app-office/abiword/abiword-3.0.0.ebuild)5
-rw-r--r--app-office/abiword/files/abiword-3.0.0-fix-crash.patch33
3 files changed, 44 insertions, 2 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 102ccaee30d5..d94abf180e32 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/abiword
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.265 2013/10/15 20:47:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.266 2013/10/17 20:41:51 pacho Exp $
+
+*abiword-3.0.0-r1 (17 Oct 2013)
+
+ 17 Oct 2013; Pacho Ramos <pacho@gentoo.org> +abiword-3.0.0-r1.ebuild,
+ +files/abiword-3.0.0-fix-crash.patch, -abiword-3.0.0.ebuild:
+ Apply upstream fix to solve abiword-docs building in the right way
15 Oct 2013; Pacho Ramos <pacho@gentoo.org> abiword-3.0.0.ebuild:
DEPEND on fixed ots letting the plugin to compile (#488140 by croutch)
diff --git a/app-office/abiword/abiword-3.0.0.ebuild b/app-office/abiword/abiword-3.0.0-r1.ebuild
index 07511e8c119d..9fe03c3e3d79 100644
--- a/app-office/abiword/abiword-3.0.0.ebuild
+++ b/app-office/abiword/abiword-3.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-3.0.0.ebuild,v 1.3 2013/10/15 20:47:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-3.0.0-r1.ebuild,v 1.1 2013/10/17 20:41:51 pacho Exp $
EAPI=5
GCONF_DEBUG="yes"
@@ -74,6 +74,9 @@ src_prepare() {
# http://bugzilla.abisource.com/show_bug.cgi?id=13532
epatch "${FILESDIR}/${PN}-3.0.0-eds-3.6.patch"
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13564
+ epatch "${FILESDIR}/${PN}-3.0.0-fix-crash.patch"
+
gnome2_src_prepare
}
diff --git a/app-office/abiword/files/abiword-3.0.0-fix-crash.patch b/app-office/abiword/files/abiword-3.0.0-fix-crash.patch
new file mode 100644
index 000000000000..bce09d18c3b2
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.0-fix-crash.patch
@@ -0,0 +1,33 @@
+commit e0e81e6c2d7f2478b9effc8476b62425ca2c12cd
+Author: Hubert Figuière <hub@figuiere.net>
+Date: Wed Oct 16 22:48:36 2013 -0400
+
+ Bug 13564 - Fix crash in abw to HTML conversion.
+
+diff --git a/src/wp/impexp/xp/ie_exp_HTML_Listener.cpp b/src/wp/impexp/xp/ie_exp_HTML_Listener.cpp
+index 86c57ec..b9dace1 100644
+--- a/src/wp/impexp/xp/ie_exp_HTML_Listener.cpp
++++ b/src/wp/impexp/xp/ie_exp_HTML_Listener.cpp
+@@ -2232,12 +2232,18 @@ void IE_Exp_HTML_Listener::_openList(PT_AttrPropIndex api, bool recursiveCall)
+ _openList(api, true);
+ }
+ }
+-
+- }else
++ }
++ else
+ {
+- const gchar* szListStyle;
++ const gchar* szListStyle = NULL;
+ pAP->getProperty("list-style", szListStyle);
+- bool isOrdered = g_ascii_strcasecmp(szListStyle, "Bullet List") != 0;
++ bool isOrdered = szListStyle
++ && (g_ascii_strcasecmp(szListStyle, "Bullet List") != 0);
++#ifdef DEBUG
++ if(!szListStyle) {
++ UT_DEBUGMSG(("***BUG*** szListStyle is NULL - http://bugzilla.abisource.com/show_bug.cgi?id=13564\n"));
++ }
++#endif
+ ListInfo info;
+ if (iCurrentLevel == 0)
+ {