summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-07 08:59:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-07 08:59:48 +0000
commit065ad8c7e618f517f18b2741e6381748b0210ea6 (patch)
tree79ae17838d629536f826c672ac0e72c799104578 /app-office/abiword
parentVersion bump. (diff)
downloadgentoo-2-065ad8c7e618f517f18b2741e6381748b0210ea6.tar.gz
gentoo-2-065ad8c7e618f517f18b2741e6381748b0210ea6.tar.bz2
gentoo-2-065ad8c7e618f517f18b2741e6381748b0210ea6.zip
Fix building with libpng15 wrt #356287 by Hanno Boeck
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog6
-rw-r--r--app-office/abiword/abiword-2.8.6-r1.ebuild8
-rw-r--r--app-office/abiword/files/abiword-2.8.6-libpng15.patch33
3 files changed, 43 insertions, 4 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 5f57bef0f242..9c055418ea43 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/abiword
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.245 2011/08/04 16:29:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.246 2011/08/07 08:59:48 ssuominen Exp $
+
+ 07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> abiword-2.8.6-r1.ebuild,
+ +files/abiword-2.8.6-libpng15.patch:
+ Fix building with libpng15 wrt #356287 by Hanno Boeck
04 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org> abiword-2.8.6-r1.ebuild:
media-libs/libwpg app-text/libwpg
diff --git a/app-office/abiword/abiword-2.8.6-r1.ebuild b/app-office/abiword/abiword-2.8.6-r1.ebuild
index 01a51bf64e92..ae94b7a790c8 100644
--- a/app-office/abiword/abiword-2.8.6-r1.ebuild
+++ b/app-office/abiword/abiword-2.8.6-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.8.6-r1.ebuild,v 1.10 2011/08/04 16:29:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.8.6-r1.ebuild,v 1.11 2011/08/07 08:59:48 ssuominen Exp $
EAPI="3"
-inherit alternatives gnome2 versionator
+inherit alternatives eutils gnome2 versionator
MY_MAJORV=$(get_version_component_range 1-2)
@@ -27,7 +27,7 @@ RDEPEND="
>=gnome-base/librsvg-2.16:2
>=gnome-extra/libgsf-1.14.15
>=media-libs/libpng-1.2
- virtual/jpeg:0
+ virtual/jpeg
>=x11-libs/cairo-1.8[X]
>=x11-libs/gtk+-2.14:2[cups?]
gnome? (
@@ -117,6 +117,8 @@ src_configure() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
gnome2_src_prepare
# install icon to pixmaps (bug #220097)
diff --git a/app-office/abiword/files/abiword-2.8.6-libpng15.patch b/app-office/abiword/files/abiword-2.8.6-libpng15.patch
new file mode 100644
index 000000000000..b9853e80a4fd
--- /dev/null
+++ b/app-office/abiword/files/abiword-2.8.6-libpng15.patch
@@ -0,0 +1,33 @@
+http://bugzilla.abisource.com/show_bug.cgi?id=13008
+
+--- src/af/util/xp/ut_png.cpp
++++ src/af/util/xp/ut_png.cpp
+@@ -71,7 +71,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, static_cast<png_infopp>(NULL));
+--- src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp
++++ src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp
+@@ -185,7 +185,7 @@
+ /** needed for the stejmp context */
+ UT_Error IE_ImpGraphic_GdkPixbuf::_png_write(GdkPixbuf * pixbuf)
+ {
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ DELETEP(m_pPngBB);
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);
+@@ -446,7 +446,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(m_pPNG->jmpbuf))
++ if (setjmp(png_jmpbuf(m_pPNG)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&m_pPNG, &m_pPNGInfo);