summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-03-22 16:52:59 +0000
committerAlin Năstac <mrness@gentoo.org>2009-03-22 16:52:59 +0000
commitaeb0f7a1a00d03f5fa449262ab37dd6433b9bf8a (patch)
tree94d14efdbd80513a60b2e69f8d64d73370f33a4a /app-mobilephone
parentold (diff)
downloadgentoo-2-aeb0f7a1a00d03f5fa449262ab37dd6433b9bf8a.tar.gz
gentoo-2-aeb0f7a1a00d03f5fa449262ab37dd6433b9bf8a.tar.bz2
gentoo-2-aeb0f7a1a00d03f5fa449262ab37dd6433b9bf8a.zip
Fix compile error when bluetooth support is disabled.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/ChangeLog6
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch46
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23.ebuild4
3 files changed, 53 insertions, 3 deletions
diff --git a/app-mobilephone/obexftp/ChangeLog b/app-mobilephone/obexftp/ChangeLog
index fb3330ce710f..5d745f06fd00 100644
--- a/app-mobilephone/obexftp/ChangeLog
+++ b/app-mobilephone/obexftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/obexftp
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.46 2009/03/06 03:08:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.47 2009/03/22 16:52:59 mrness Exp $
+
+ 22 Mar 2009; Alin Năstac <mrness@gentoo.org>
+ +files/obexftp-0.23-gentoo.patch, obexftp-0.23.ebuild:
+ Fix compile error when bluetooth support is disabled.
06 Mar 2009; Jeroen Roovers <jer@gentoo.org> obexftp-0.22.ebuild:
Stable for HPPA (bug #245455).
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000000..a9a70f79168d
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
@@ -0,0 +1,46 @@
+diff -Nru obexftp-0.23.orig/obexftp/client.c obexftp-0.23/obexftp/client.c
+--- obexftp-0.23.orig/obexftp/client.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/obexftp/client.c 2009-03-22 16:12:05.000000000 +0000
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+diff -Nru obexftp-0.23.orig/apps/obexftp.c obexftp-0.23/apps/obexftp.c
+--- obexftp-0.23.orig/apps/obexftp.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/apps/obexftp.c 2009-03-22 16:19:29.000000000 +0000
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
+diff -Nru obexftp-0.23.orig/swig/ruby/extconf.rb obexftp-0.23/swig/ruby/extconf.rb
+--- obexftp-0.23.orig/swig/ruby/extconf.rb 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/swig/ruby/extconf.rb 2009-03-22 16:19:56.000000000 +0000
+@@ -21,10 +21,6 @@
+ end
+
+ dir_config('obexftp')
+-if have_library('openobex', 'OBEX_Init') and
+- find_library('bfb', 'bfb_io_open', '../../bfb/.libs') and
+- find_library('multicobex', 'cobex_ctrans', '../../multicobex/.libs') and
+- find_library('obexftp', 'obexftp_open', '../../obexftp/.libs')
+ create_makefile('obexftp')
+
+ # hack 2: strip all rpath references
+@@ -33,7 +29,3 @@
+ out.puts line.gsub(/-Wl,-R'[^']*'/, '')
+ end
+ end
+-else
+- puts 'obex libs not found'
+-end
+-
diff --git a/app-mobilephone/obexftp/obexftp-0.23.ebuild b/app-mobilephone/obexftp/obexftp-0.23.ebuild
index 14fa5716f77a..7c2d54f38638 100644
--- a/app-mobilephone/obexftp/obexftp-0.23.ebuild
+++ b/app-mobilephone/obexftp/obexftp-0.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23.ebuild,v 1.1 2009/02/28 00:02:28 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23.ebuild,v 1.2 2009/03/22 16:52:59 mrness Exp $
EAPI="2"
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.22-ruby-libpath.patch"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
}
src_configure() {