summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-10-13 20:38:24 +0000
committerAlin Năstac <mrness@gentoo.org>2006-10-13 20:38:24 +0000
commit89ede71ecd0d11dd24917a585dc9897b65013065 (patch)
tree052d3e44d2c2a80a3fd813e98b650aac362ec604 /app-mobilephone
parentDrop lesstif USE flag and depend on virtual/motif. (diff)
downloadgentoo-2-89ede71ecd0d11dd24917a585dc9897b65013065.tar.gz
gentoo-2-89ede71ecd0d11dd24917a585dc9897b65013065.tar.bz2
gentoo-2-89ede71ecd0d11dd24917a585dc9897b65013065.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/files/digest-wammu-0.163
-rw-r--r--app-mobilephone/wammu/wammu-0.16.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index c1eac7c92e29..d896317e6d8a 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.12 2006/09/17 13:27:16 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.13 2006/10/13 20:38:24 mrness Exp $
+
+*wammu-0.16 (13 Oct 2006)
+
+ 13 Oct 2006; Alin Nastac <mrness@gentoo.org> +wammu-0.16.ebuild:
+ Version bump.
*wammu-0.15 (17 Sep 2006)
diff --git a/app-mobilephone/wammu/files/digest-wammu-0.16 b/app-mobilephone/wammu/files/digest-wammu-0.16
new file mode 100644
index 000000000000..1cd0a7be4617
--- /dev/null
+++ b/app-mobilephone/wammu/files/digest-wammu-0.16
@@ -0,0 +1,3 @@
+MD5 2f0367fc2d498540081166f878f8ac66 wammu-0.16.tar.bz2 210041
+RMD160 f5791843fd600be1793fafca48ed66ff5ced8d04 wammu-0.16.tar.bz2 210041
+SHA256 145e8bc78199d3c105f2c758cbd32acda72bfd278a875b9f0d73cddaa4fd4ecf wammu-0.16.tar.bz2 210041
diff --git a/app-mobilephone/wammu/wammu-0.16.ebuild b/app-mobilephone/wammu/wammu-0.16.ebuild
new file mode 100644
index 000000000000..926375721e07
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.16.ebuild,v 1.1 2006/10/13 20:38:24 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+#gnome-bluetooth is used for additional functionality - see bug #101067
+RDEPEND=">=dev-python/wxpython-2.6
+ >=dev-python/python-gammu-0.15
+ bluetooth? (
+ net-wireless/gnome-bluetooth
+ !amd64? ( dev-python/pybluez )
+ )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}