summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-11 06:22:17 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-11 06:22:17 +0000
commit7a598ddad8516b63f1ed44bfaaa25aa7c2e24c31 (patch)
tree44e71c33e4b38d29b68f2cdaeb3a982d45187338 /app-mobilephone
parentversion bump (diff)
downloadgentoo-2-7a598ddad8516b63f1ed44bfaaa25aa7c2e24c31.tar.gz
gentoo-2-7a598ddad8516b63f1ed44bfaaa25aa7c2e24c31.tar.bz2
gentoo-2-7a598ddad8516b63f1ed44bfaaa25aa7c2e24c31.zip
revbump, conversion -> distutils-r1, add IUSE examples, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/lightblue/ChangeLog10
-rw-r--r--app-mobilephone/lightblue/lightblue-0.4-r1.ebuild26
-rw-r--r--app-mobilephone/lightblue/lightblue-0.4.ebuild23
3 files changed, 34 insertions, 25 deletions
diff --git a/app-mobilephone/lightblue/ChangeLog b/app-mobilephone/lightblue/ChangeLog
index a9e81f21a84d..0dd9a200037f 100644
--- a/app-mobilephone/lightblue/ChangeLog
+++ b/app-mobilephone/lightblue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/lightblue
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/lightblue/ChangeLog,v 1.5 2013/11/07 02:50:27 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/lightblue/ChangeLog,v 1.6 2015/02/11 06:22:17 idella4 Exp $
+
+*lightblue-0.4-r1 (11 Feb 2015)
+
+ 11 Feb 2015; Ian Delaney <idella4@gentoo.org> +lightblue-0.4-r1.ebuild,
+ -lightblue-0.4.ebuild:
+ revbump, conversion -> distutils-r1, add IUSE examples, rm old
07 Nov 2013; Patrick Lauer <patrick@gentoo.org> lightblue-0.4.ebuild:
Shorten description, make repoman happier
diff --git a/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild b/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild
new file mode 100644
index 000000000000..7bb091d8bd7c
--- /dev/null
+++ b/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/lightblue/lightblue-0.4-r1.ebuild,v 1.1 2015/02/11 06:22:17 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform Bluetooth API for Python which provides simple access to Bluetooth operations"
+HOMEPAGE="http://lightblue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=dev-libs/openobex-1.3"
+DEPEND=">=dev-python/pybluez-0.9[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
diff --git a/app-mobilephone/lightblue/lightblue-0.4.ebuild b/app-mobilephone/lightblue/lightblue-0.4.ebuild
deleted file mode 100644
index 13b447d7556d..000000000000
--- a/app-mobilephone/lightblue/lightblue-0.4.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/lightblue/lightblue-0.4.ebuild,v 1.4 2013/11/07 02:50:27 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Cross-platform Bluetooth API for Python which provides simple access to Bluetooth operations"
-HOMEPAGE="http://lightblue.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-libs/openobex-1.3
- >=dev-python/pybluez-0.9"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"