summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-10-24 08:43:00 +0000
committerAlin Năstac <mrness@gentoo.org>2006-10-24 08:43:00 +0000
commit6839a2a257ce374b6040bf8311b7034263d0a391 (patch)
treedc81b7ef41d9558d117e63d80622ff71934992c7 /app-mobilephone
parentDisable PIE support in FreeBSD, as there it does not work, fixes kde not star... (diff)
downloadgentoo-2-6839a2a257ce374b6040bf8311b7034263d0a391.tar.gz
gentoo-2-6839a2a257ce374b6040bf8311b7034263d0a391.tar.bz2
gentoo-2-6839a2a257ce374b6040bf8311b7034263d0a391.zip
Use audacious instead xmms (#152477).
(Portage version: 2.1.1)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/bemused/ChangeLog9
-rw-r--r--app-mobilephone/bemused/bemused-1.73-r1.ebuild40
-rw-r--r--app-mobilephone/bemused/files/bemused-1.73-audacious.patch71
-rw-r--r--app-mobilephone/bemused/files/digest-bemused-1.73-r13
4 files changed, 122 insertions, 1 deletions
diff --git a/app-mobilephone/bemused/ChangeLog b/app-mobilephone/bemused/ChangeLog
index aaf7dd9552b5..b3fe9a33ec2d 100644
--- a/app-mobilephone/bemused/ChangeLog
+++ b/app-mobilephone/bemused/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/bemused
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/ChangeLog,v 1.4 2006/06/28 17:51:45 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/ChangeLog,v 1.5 2006/10/24 08:43:00 mrness Exp $
+
+*bemused-1.73-r1 (24 Oct 2006)
+
+ 24 Oct 2006; Alin Nastac <mrness@gentoo.org>
+ +files/bemused-1.73-audacious.patch, -bemused-1.73.ebuild,
+ +bemused-1.73-r1.ebuild:
+ Use audacious instead xmms (#152477).
28 Jun 2006; Alin Nastac <mrness@gentoo.org>
+files/bemused-1.73-gcc41.patch, bemused-1.73.ebuild:
diff --git a/app-mobilephone/bemused/bemused-1.73-r1.ebuild b/app-mobilephone/bemused/bemused-1.73-r1.ebuild
new file mode 100644
index 000000000000..c01b8a173d6c
--- /dev/null
+++ b/app-mobilephone/bemused/bemused-1.73-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bemused/bemused-1.73-r1.ebuild,v 1.1 2006/10/24 08:43:00 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Bemused is a system which allows you to control your music collection from your phone, using Bluetooth."
+HOMEPAGE="http://bemused.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}linuxserver-${PV/./_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}linuxserver${PV}"
+
+RDEPEND="media-sound/audacious
+ net-wireless/bluez-libs"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+ epatch "${FILESDIR}/${P}-audacious.patch"
+}
+
+src_install() {
+ dobin bemusedlinuxserver
+ insinto /etc
+ doins bemused.conf
+
+ dodoc ChangeLog authors copying readme todo
+
+ einfo "Please note that due to the specific hardware nature"
+ einfo "of this package, only upstream support can be"
+ einfo "provided!"
+}
diff --git a/app-mobilephone/bemused/files/bemused-1.73-audacious.patch b/app-mobilephone/bemused/files/bemused-1.73-audacious.patch
new file mode 100644
index 000000000000..adc4fb5a5e25
--- /dev/null
+++ b/app-mobilephone/bemused/files/bemused-1.73-audacious.patch
@@ -0,0 +1,71 @@
+diff -Nru bemusedlinuxserver1.73.orig/bemused.conf bemusedlinuxserver1.73/bemused.conf
+--- bemusedlinuxserver1.73.orig/bemused.conf 2006-10-24 11:34:29.000000000 +0300
++++ bemusedlinuxserver1.73/bemused.conf 2006-10-24 11:34:36.000000000 +0300
+@@ -1,12 +1,13 @@
+ # bemused config file Version 1.73 (no changes since 1.71)
++# Gentoo-specific changes: Audacious as a default player instead of xmms
+
+ # lines with a # at the beinning are for comments and not readen by the bemusedserver
+
+ # You only need to set up options which have no default and which ware not optinal
+
+
+-# Path to xmms (if xmms is in path only xmms) (default is xmms)
+-xmmsdir=xmms
++# Path to xmms-compatible player (default is audacious)
++xmmsdir=audacious
+
+ # channel for what the serial port service is registered (with sdptool look in README) (default 10)
+ #channel=10
+diff -Nru bemusedlinuxserver1.73.orig/BemusedServerDlg.cpp bemusedlinuxserver1.73/BemusedServerDlg.cpp
+--- bemusedlinuxserver1.73.orig/BemusedServerDlg.cpp 2006-10-24 11:34:29.000000000 +0300
++++ bemusedlinuxserver1.73/BemusedServerDlg.cpp 2006-10-24 11:34:36.000000000 +0300
+@@ -46,7 +46,7 @@
+ #include <affix/sdpsrv.h>
+ #endif
+
+-#include <xmmsctrl.h>
++#include <beepctrl.h>
+
+ #include "BemusedServerDlg.h"
+
+@@ -232,7 +232,7 @@
+ tcpport=7654;
+ channel=10;
+ tcp=false;
+- strcpy(winampPath,"xmms");
++ strcpy(winampPath,"audacious");
+ startAutomatically=1;
+ ifstream conffile("/etc/bemused.conf");
+ if (!conffile) {
+diff -Nru bemusedlinuxserver1.73.orig/Makefile bemusedlinuxserver1.73/Makefile
+--- bemusedlinuxserver1.73.orig/Makefile 2006-10-24 11:34:29.000000000 +0300
++++ bemusedlinuxserver1.73/Makefile 2006-10-24 11:36:17.000000000 +0300
+@@ -1,10 +1,10 @@
+
+ SHELL = /bin/sh
+-LIB = -lxmms -lbluetooth
+-INCL = -I/usr/include/xmms -I./
++LIB = -lbluetooth
++INCL = -I/usr/include/audacious -I./
+
+ bemusedlinuxserver: main.cpp BemusedServerDlg.cpp
+- $(CXX) -o bemusedlinuxserver $(INCL) $(LIB) `gtk-config --libs --cflags` main.cpp BemusedServerDlg.cpp
++ $(CXX) -o bemusedlinuxserver $(INCL) $(LIB) `pkg-config audacious --libs --cflags` main.cpp BemusedServerDlg.cpp
+
+
+ install: bemusedlinuxserver
+diff -Nru bemusedlinuxserver1.73.orig/Makefile.affix bemusedlinuxserver1.73/Makefile.affix
+--- bemusedlinuxserver1.73.orig/Makefile.affix 2006-10-24 11:34:29.000000000 +0300
++++ bemusedlinuxserver1.73/Makefile.affix 2006-10-24 11:34:36.000000000 +0300
+@@ -1,8 +1,8 @@
+ # Makefile for compiling Bemused for Affix
+ # 2004, Andrei Emeltchenko
+
+-LIBS = -lxmms -laffix -laffix_sdp -laffix_sdpsvc -L/usr/local/lib
+-INCL = -I/usr/include/xmms -I./
++LIBS = -laudacious -laffix -laffix_sdp -laffix_sdpsvc -L/usr/local/lib
++INCL = -I/usr/include/audacious -I./
+ CXXFLAGS = $(INCL) -DAFFIX `gtk-config --cflags`
+ LDFLAGS = $(LIBS)
+
diff --git a/app-mobilephone/bemused/files/digest-bemused-1.73-r1 b/app-mobilephone/bemused/files/digest-bemused-1.73-r1
new file mode 100644
index 000000000000..1698281e123e
--- /dev/null
+++ b/app-mobilephone/bemused/files/digest-bemused-1.73-r1
@@ -0,0 +1,3 @@
+MD5 d6f0198771c06ea8a7eb96b6a28acc11 bemusedlinuxserver-1_73.tar.gz 77143
+RMD160 8a1f88201c96eb3592462c88826497c2b224e380 bemusedlinuxserver-1_73.tar.gz 77143
+SHA256 efa0c787f1ccde036c03e4eb066ef6d0dac98798ec37098b2a70ce2a02638546 bemusedlinuxserver-1_73.tar.gz 77143