summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-27 21:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-27 21:56:33 +0000
commit21f0bc54e1862856a8eaf6a209664b1b251fe33f (patch)
treeb2bd6e6bca1ffb0918d0c77c17ab24e38ab323d4 /app-mobilephone
parentAdding ~amd64 ~x86 keywords, drop 6.5.4. (diff)
downloadgentoo-2-21f0bc54e1862856a8eaf6a209664b1b251fe33f.tar.gz
gentoo-2-21f0bc54e1862856a8eaf6a209664b1b251fe33f.tar.bz2
gentoo-2-21f0bc54e1862856a8eaf6a209664b1b251fe33f.zip
Convert to EAPI=4 and update various autotool features #467586 by Ian Stakenvicius.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/tsemgr/ChangeLog9
-rw-r--r--app-mobilephone/tsemgr/files/tsemgr-0.08-build.patch29
-rw-r--r--app-mobilephone/tsemgr/tsemgr-0.08.ebuild19
3 files changed, 41 insertions, 16 deletions
diff --git a/app-mobilephone/tsemgr/ChangeLog b/app-mobilephone/tsemgr/ChangeLog
index 53c500b7162c..29bef49b6d6b 100644
--- a/app-mobilephone/tsemgr/ChangeLog
+++ b/app-mobilephone/tsemgr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/tsemgr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/tsemgr/ChangeLog,v 1.5 2012/05/02 20:10:08 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/tsemgr/ChangeLog,v 1.6 2013/04/27 21:56:33 vapier Exp $
+
+ 27 Apr 2013; Mike Frysinger <vapier@gentoo.org> files/tsemgr-0.08-build.patch,
+ tsemgr-0.08.ebuild:
+ Convert to EAPI=4 and update various autotool features #467586 by Ian
+ Stakenvicius.
02 May 2012; Jeff Horelick <jdhore@gentoo.org> tsemgr-0.08.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/app-mobilephone/tsemgr/files/tsemgr-0.08-build.patch b/app-mobilephone/tsemgr/files/tsemgr-0.08-build.patch
index 7567200181dc..d0df17ca1b5e 100644
--- a/app-mobilephone/tsemgr/files/tsemgr-0.08-build.patch
+++ b/app-mobilephone/tsemgr/files/tsemgr-0.08-build.patch
@@ -1,5 +1,22 @@
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,14 +1,13 @@
+ AC_INIT(tsemgr, 0.08)
+-VERSION=0.08
+ AC_PREREQ(2.53)
+
+-AM_INIT_AUTOMAKE(tsemgr, $VERSION)
++AM_INIT_AUTOMAKE
+
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ # Defines
+ AC_DEFINE(TSEMGR_BASE_CONFIG_DIR, [".tsemgr"], [Base config directory.])
@@ -16,34 +16,17 @@ AC_DEFINE(REMOTE_CTREE_FILE, ["tsemgr_re
AC_DEFINE(BASE_CONFIG_FILE, ["tsemgr.conf"], [Default config file.])
@@ -41,3 +58,11 @@
# Look for the ezV24 library.
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,4 @@
+-INCLUDES = -I$(top_srcdir)
++AM_CPPFLAGS = -I$(top_srcdir)
+
+ bin_PROGRAMS = tsemgr
+
diff --git a/app-mobilephone/tsemgr/tsemgr-0.08.ebuild b/app-mobilephone/tsemgr/tsemgr-0.08.ebuild
index 3f8c29a5fd04..8312395ebc74 100644
--- a/app-mobilephone/tsemgr/tsemgr-0.08.ebuild
+++ b/app-mobilephone/tsemgr/tsemgr-0.08.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/tsemgr/tsemgr-0.08.ebuild,v 1.6 2012/05/02 20:10:08 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/tsemgr/tsemgr-0.08.ebuild,v 1.7 2013/04/27 21:56:33 vapier Exp $
+
+EAPI="4"
inherit eutils autotools
@@ -16,17 +18,10 @@ IUSE=""
RDEPEND="=x11-libs/gtk+-1*
dev-libs/openobex
dev-libs/libezV24"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-build.patch
eautoreconf
}
-
-src_install(){
- emake DESTDIR="${D}" install || die "Installation failed."
- dodoc README NEWS TODO AUTHORS
-}