summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-13 20:03:26 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-13 20:03:26 +0000
commit2d12dd4bf32855756f6eec0f17e316155fe934d1 (patch)
treed8c344ad43f9277f7275f5462631cc5b3437f263 /app-mobilephone/sms/sms-2.0.3.ebuild
parentManifest recommit (diff)
downloadgentoo-2-2d12dd4bf32855756f6eec0f17e316155fe934d1.tar.gz
gentoo-2-2d12dd4bf32855756f6eec0f17e316155fe934d1.tar.bz2
gentoo-2-2d12dd4bf32855756f6eec0f17e316155fe934d1.zip
Simplify dependencies.
(Portage version: 2.0.54)
Diffstat (limited to 'app-mobilephone/sms/sms-2.0.3.ebuild')
-rw-r--r--app-mobilephone/sms/sms-2.0.3.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-mobilephone/sms/sms-2.0.3.ebuild b/app-mobilephone/sms/sms-2.0.3.ebuild
index 51aa8114119e..5c129a6e2936 100644
--- a/app-mobilephone/sms/sms-2.0.3.ebuild
+++ b/app-mobilephone/sms/sms-2.0.3.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/sms/sms-2.0.3.ebuild,v 1.2 2005/07/13 22:09:22 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/sms/sms-2.0.3.ebuild,v 1.3 2006/04/13 20:03:26 mrness Exp $
inherit toolchain-funcs
DESCRIPTION="Command line program for sending SMS to Polish GSM mobile phone users"
HOMEPAGE="http://ceti.pl/~miki/komputery/sms.html"
SRC_URI="http://ceti.pl/~miki/komputery/download/sms/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
IUSE=""
-RDEPEND="virtual/libc
- sys-libs/gdbm
+
+DEPEND="sys-libs/gdbm
dev-libs/libpcre
dev-libs/pcre++
net-misc/curl"
-DEPEND="${RDEPEND}
- sys-devel/gcc
- sys-apps/sed"
-
src_compile() {
- emake CXX=$(tc-getCXX) CXXFLAGS="${CXXFLAGS} -I./lib" LDFLAGS="-lc" || die
+ emake CXX=$(tc-getCXX) CXXFLAGS="${CXXFLAGS} -I./lib" LDFLAGS="-lc" || die "make failed"
}
src_install() {