summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-06 00:56:02 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-06 00:56:02 +0000
commit82a2065a9f6e4aaf98cd8c930f8ed5556cd5391a (patch)
tree75d672d84052093213d7bcc14d8772ffa26f5e5f /app-mobilephone/openmoko-dfu-util
parentVersion bumped. (diff)
downloadgentoo-2-82a2065a9f6e4aaf98cd8c930f8ed5556cd5391a.tar.gz
gentoo-2-82a2065a9f6e4aaf98cd8c930f8ed5556cd5391a.tar.bz2
gentoo-2-82a2065a9f6e4aaf98cd8c930f8ed5556cd5391a.zip
Initial ebuild by mikael lammentausta, Florian Steinel, and Bastien Lacoste #201920.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-mobilephone/openmoko-dfu-util')
-rw-r--r--app-mobilephone/openmoko-dfu-util/ChangeLog11
-rw-r--r--app-mobilephone/openmoko-dfu-util/Manifest3
-rw-r--r--app-mobilephone/openmoko-dfu-util/metadata.xml5
-rw-r--r--app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild27
4 files changed, 46 insertions, 0 deletions
diff --git a/app-mobilephone/openmoko-dfu-util/ChangeLog b/app-mobilephone/openmoko-dfu-util/ChangeLog
new file mode 100644
index 000000000000..9bf14a499b3b
--- /dev/null
+++ b/app-mobilephone/openmoko-dfu-util/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-mobilephone/openmoko-dfu-util
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/openmoko-dfu-util/ChangeLog,v 1.1 2008/09/06 00:56:02 vapier Exp $
+
+*openmoko-dfu-util-9999 (06 Sep 2008)
+
+ 06 Sep 2008; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +openmoko-dfu-util-9999.ebuild:
+ Initial ebuild by mikael lammentausta, Florian Steinel, and Bastien
+ Lacoste #201920.
+
diff --git a/app-mobilephone/openmoko-dfu-util/Manifest b/app-mobilephone/openmoko-dfu-util/Manifest
new file mode 100644
index 000000000000..26cb5d74a737
--- /dev/null
+++ b/app-mobilephone/openmoko-dfu-util/Manifest
@@ -0,0 +1,3 @@
+EBUILD openmoko-dfu-util-9999.ebuild 636 RMD160 7bb14bc3df3ae9a63ff447e61c9dce5e43aee10f SHA1 d9ea42fecd0e6ccb6655002a9044aa79a6341f69 SHA256 88e797318349473c36855e2337134b0ca673ee0016bcb95e227f38f70aa1234f
+MISC ChangeLog 362 RMD160 a30b7be1e3e7c50d43e3358a5c7383720fbd9503 SHA1 877d00fc36399bfe64502e49b894201c9e2c30be SHA256 4a84b2d0e1dbd542d4e7a770f65a446d09826bca29d46169a1bcacd764d70967
+MISC metadata.xml 169 RMD160 2eb7a9de9da64a2dca3036e565215786a0b5220f SHA1 1a3d10ddf2fbc70c0cc2ddcbd31728096ed0c657 SHA256 30879f99d98730d40c105c863e9b579ac992c8f98245eb7eac9ca65360104611
diff --git a/app-mobilephone/openmoko-dfu-util/metadata.xml b/app-mobilephone/openmoko-dfu-util/metadata.xml
new file mode 100644
index 000000000000..7e4762f7ccd0
--- /dev/null
+++ b/app-mobilephone/openmoko-dfu-util/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile-phone</herd>
+</pkgmetadata>
diff --git a/app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild b/app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild
new file mode 100644
index 000000000000..18b90c01c888
--- /dev/null
+++ b/app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/openmoko-dfu-util/openmoko-dfu-util-9999.ebuild,v 1.1 2008/09/06 00:56:02 vapier Exp $
+
+ESVN_REPO_URI="http://svn.openmoko.org/trunk/src/host/dfu-util/"
+inherit subversion autotools
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ sed -i '/^bin_PROGRAMS/s:dfu-util_static::' src/Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Make install failed"
+}