summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-04-25 10:53:49 +0000
committerAlin Năstac <mrness@gentoo.org>2009-04-25 10:53:49 +0000
commitb99dc925f367b8e1783886f7c05dbd40cc8d738a (patch)
tree269d8c5d179992f1d72eab1eee3a38925a9a351f /app-mobilephone/obexftp/files
parentInitial commit. Fixes #267387. Ebuild by Ronan Bignaux. (diff)
downloadgentoo-2-b99dc925f367b8e1783886f7c05dbd40cc8d738a.tar.gz
gentoo-2-b99dc925f367b8e1783886f7c05dbd40cc8d738a.tar.bz2
gentoo-2-b99dc925f367b8e1783886f7c05dbd40cc8d738a.zip
Restrict ruby dependency atom to slot 1.8 (#261736).
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/obexftp/files')
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.21-as-needed.patch31
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.21-cobex_write.patch60
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.21-no_iconv.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch44
4 files changed, 0 insertions, 146 deletions
diff --git a/app-mobilephone/obexftp/files/obexftp-0.21-as-needed.patch b/app-mobilephone/obexftp/files/obexftp-0.21-as-needed.patch
deleted file mode 100644
index 15595782e0ed..000000000000
--- a/app-mobilephone/obexftp/files/obexftp-0.21-as-needed.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Nru obexftp-0.21.orig/multicobex/Makefile.am obexftp-0.21/multicobex/Makefile.am
---- obexftp-0.21.orig/multicobex/Makefile.am 2007-04-28 20:13:54.000000000 +0200
-+++ obexftp-0.21/multicobex/Makefile.am 2007-04-30 13:39:36.000000000 +0200
-@@ -4,7 +4,7 @@
- -I$(top_srcdir) \
- -I$(top_srcdir)/includes
-
--LDADD = @OPENOBEX_LIBS@ \
-+libmulticobex_la_LIBADD = @OPENOBEX_LIBS@ \
- ../bfb/libbfb.la
-
- multicobexincludedir = $(includedir)/multicobex
-diff -Nru obexftp-0.21.orig/obexftp/Makefile.am obexftp-0.21/obexftp/Makefile.am
---- obexftp-0.21.orig/obexftp/Makefile.am 2007-04-28 20:13:54.000000000 +0200
-+++ obexftp-0.21/obexftp/Makefile.am 2007-04-30 14:04:22.000000000 +0200
-@@ -4,11 +4,10 @@
- -I$(top_srcdir) \
- -I$(top_srcdir)/includes
-
--LDADD = @OPENOBEX_LIBS@
--# @BLUETOOTH_LIBS@ \
--# @USB_LIBS@ \
--# ../multicobex/libmulticobex.la \
--# ../bfb/libbfb.la
-+libobexftp_la_LIBADD = @OPENOBEX_LIBS@ \
-+ @BLUETOOTH_LIBS@ \
-+ ../multicobex/libmulticobex.la \
-+ ../bfb/libbfb.la
-
- obexftpincludedir = $(includedir)/obexftp
-
diff --git a/app-mobilephone/obexftp/files/obexftp-0.21-cobex_write.patch b/app-mobilephone/obexftp/files/obexftp-0.21-cobex_write.patch
deleted file mode 100644
index db80309a5d8a..000000000000
--- a/app-mobilephone/obexftp/files/obexftp-0.21-cobex_write.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -Nru obexftp-0.21.orig/multicobex/multi_cobex.c obexftp-0.21/multicobex/multi_cobex.c
---- obexftp-0.21.orig/multicobex/multi_cobex.c 2005-11-24 16:55:11.000000000 +0200
-+++ obexftp-0.21/multicobex/multi_cobex.c 2006-06-02 21:53:07.483151000 +0300
-@@ -126,7 +126,7 @@
- /* Called from OBEX-lib when data needs to be written */
- int cobex_write(obex_t *self, void *data, uint8_t *buffer, int length)
- {
-- int actual;
-+ int written;
- cobex_t *c;
- return_val_if_fail (self != NULL, -1);
- return_val_if_fail (data != NULL, -1);
-@@ -137,24 +137,37 @@
- DEBUG(3, "%s() Data %d bytes\n", __func__, length);
-
- if (c->type == CT_ERICSSON || c->type == CT_SIEMENS) {
-- actual = write(c->fd, buffer, length);
-- if (actual < length) {
-- DEBUG(1, "Error writing to port (%d expected %d)\n", actual, length);
-- return actual; /* or -1? */
-+ int retries=0, chunk, fails=0;
-+ written = 0;
-+ for (retries = 0; written < length; retries++) {
-+ chunk = write(c->fd, buffer+written, length-written);
-+ if (chunk <= 0) {
-+ if ( ++fails >= 10 ) { // to avoid infinite looping if something is really wrong
-+ DEBUG(1, "%s() Error writing to port (written %d bytes out of %d, in %d retries)\n", __func__, written, length, retries);
-+ return written;
-+ }
-+ usleep(1); // This mysteriously avoids a resource not available error on write()
-+ } else {
-+ written += chunk;
-+ fails = 0; // Reset error counter on successful write op
-+ }
- }
-- return actual;
-+
-+ if (retries > 0)
-+ DEBUG(2, "%s() Wrote %d bytes in %d retries\n", __func__, written, retries);
-+ return written;
- }
-
- if (c->seq == 0){
-- actual = bfb_send_first(c->fd, buffer, length);
-- DEBUG(2, "%s() Wrote %d first packets (%d bytes)\n", __func__, actual, length);
-+ written = bfb_send_first(c->fd, buffer, length);
-+ DEBUG(2, "%s() Wrote %d first packets (%d bytes)\n", __func__, written, length);
- } else {
-- actual = bfb_send_next(c->fd, buffer, length, c->seq);
-- DEBUG(2, "%s() Wrote %d packets (%d bytes)\n", __func__, actual, length);
-+ written = bfb_send_next(c->fd, buffer, length, c->seq);
-+ DEBUG(2, "%s() Wrote %d packets (%d bytes)\n", __func__, written, length);
- }
- c->seq++;
-
-- return actual;
-+ return written;
- }
-
- /* Called when input data is needed */
diff --git a/app-mobilephone/obexftp/files/obexftp-0.21-no_iconv.patch b/app-mobilephone/obexftp/files/obexftp-0.21-no_iconv.patch
deleted file mode 100644
index c6d57d11ae47..000000000000
--- a/app-mobilephone/obexftp/files/obexftp-0.21-no_iconv.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- obexftp-0.21.orig/configure.in 2006-09-22 09:23:30 +0000
-+++ obexftp-0.21/configure.in 2006-09-22 09:23:47 +0000
-@@ -24,7 +24,7 @@
- # Checks for libraries.
- PKG_CHECK_MODULES(OPENOBEX,openobex)
-
--AM_ICONV
-+dnl AM_ICONV
- dnl IRDA_CHECK
- BLUETOOTH_CHECK
- if test $am_cv_bluetooth_found = yes; then
diff --git a/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch b/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch
deleted file mode 100644
index c1cb7f183feb..000000000000
--- a/app-mobilephone/obexftp/files/obexftp-0.21-sdp-detection.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Nru obexftp-0.21.orig/apps/obexftp_sdp.c obexftp-0.21/apps/obexftp_sdp.c
---- obexftp-0.21.orig/apps/obexftp_sdp.c 2006-06-03 20:02:27.529609000 +0300
-+++ obexftp-0.21/apps/obexftp_sdp.c 2006-06-03 20:03:26.753310250 +0300
-@@ -34,6 +34,8 @@
- #include <sys/types.h>
- #include <sys/socket.h>
-
-+#ifdef HAVE_SDPLIB
-+
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/sdp.h>
- #include <bluetooth/sdp_lib.h>
-@@ -173,3 +175,17 @@
- return 0;
- }
- */
-+
-+#else
-+
-+void obexftp_sdp_unregister(void)
-+{
-+}
-+
-+int obexftp_sdp_register(void)
-+{
-+ syslog(LOG_ERR, "SDP not supported.");
-+ return -1;
-+}
-+
-+#endif // HAVE_SDPLIB
-diff -Nru obexftp-0.21.orig/configure.in obexftp-0.21/configure.in
---- obexftp-0.21.orig/configure.in 2006-06-03 20:02:27.529609000 +0300
-+++ obexftp-0.21/configure.in 2006-06-03 20:00:45.000000000 +0300
-@@ -27,7 +27,9 @@
- AM_ICONV
- dnl IRDA_CHECK
- BLUETOOTH_CHECK
--SDPLIB_CHECK
-+if test $am_cv_bluetooth_found = yes; then
-+ SDPLIB_CHECK
-+fi
- USB_CHECK
-
- # check for optional swig rebuild