summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-02-19 18:56:19 +0000
committerPacho Ramos <pacho@gentoo.org>2010-02-19 18:56:19 +0000
commitf91b616404627f95060f035246588cdee52b6cb1 (patch)
tree74a886f1dc555a818419ed6745f45f89f29f9606 /app-mobilephone/obexd
parentia64/sparc stable (diff)
downloadgentoo-2-f91b616404627f95060f035246588cdee52b6cb1.tar.gz
gentoo-2-f91b616404627f95060f035246588cdee52b6cb1.tar.bz2
gentoo-2-f91b616404627f95060f035246588cdee52b6cb1.zip
Fix bug 305063
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/obexd')
-rw-r--r--app-mobilephone/obexd/ChangeLog9
-rw-r--r--app-mobilephone/obexd/files/obexd-0.21-fix_configure.patch39
-rw-r--r--app-mobilephone/obexd/obexd-0.21-r2.ebuild (renamed from app-mobilephone/obexd/obexd-0.21-r1.ebuild)25
3 files changed, 59 insertions, 14 deletions
diff --git a/app-mobilephone/obexd/ChangeLog b/app-mobilephone/obexd/ChangeLog
index 4c2b374c45f8..7757a253ff4d 100644
--- a/app-mobilephone/obexd/ChangeLog
+++ b/app-mobilephone/obexd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/obexd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexd/ChangeLog,v 1.5 2010/02/19 13:26:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexd/ChangeLog,v 1.6 2010/02/19 18:56:19 pacho Exp $
+
+*obexd-0.21-r2 (19 Feb 2010)
+
+ 19 Feb 2010; Pacho Ramos <pacho@gentoo.org> -obexd-0.21-r1.ebuild,
+ +obexd-0.21-r2.ebuild, +files/obexd-0.21-fix_configure.patch:
+ Fixing bug 305063 properly, thanks to Vinicius Costa Gomes for the patch
+ and help. Removing old and buggy version
*obexd-0.21-r1 (19 Feb 2010)
*obexd-0.18-r1 (19 Feb 2010)
diff --git a/app-mobilephone/obexd/files/obexd-0.21-fix_configure.patch b/app-mobilephone/obexd/files/obexd-0.21-fix_configure.patch
new file mode 100644
index 000000000000..2f26bb0baa81
--- /dev/null
+++ b/app-mobilephone/obexd/files/obexd-0.21-fix_configure.patch
@@ -0,0 +1,39 @@
+From a35b4a2330ff042f362c8af69e6bbd3909a128d3 Mon Sep 17 00:00:00 2001
+From: Vinicius Costa Gomes <vinicius.gomes@openbossa.org>
+Date: Fri, 19 Feb 2010 11:34:55 -0300
+Subject: [PATCH 1/1] Fix compilation when passing the --without-<driver> option
+
+When we pass the --without-* option, the {withval} variable
+was being set to "no".
+---
+ configure.ac | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ba0f8a1..cca5ce9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -105,10 +105,9 @@ AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug],
+ CFLAGS="$CFLAGS -g"
+ fi
+ ])
+-
+ phonebook_driver=dummy
+ AC_ARG_WITH(phonebook, AC_HELP_STRING([--with-phonebook=DRIVER], [select phonebook driver]), [
+- phonebook_driver=${withval}
++ phonebook_driver=${withval}, phonebook_driver=dummy
+ ])
+
+ if (test "${phonebook_driver}" = "ebook"); then
+@@ -129,7 +128,7 @@ AC_SUBST([PHONEBOOK_DRIVER], [phonebook-${phonebook_driver}.c])
+
+ telephony_driver=dummy
+ AC_ARG_WITH(telephony, AC_HELP_STRING([--with-telephony=DRIVER], [select telephony driver]), [
+- telephony_driver=${withval}
++ telephony_driver=${withval}, telephony_driver=dummy
+ ])
+
+ AC_SUBST([TELEPHONY_DRIVER], [telephony-${telephony_driver}.c])
+--
+1.6.2.5
+
diff --git a/app-mobilephone/obexd/obexd-0.21-r1.ebuild b/app-mobilephone/obexd/obexd-0.21-r2.ebuild
index 88834dd12bd2..f84ce8c02a62 100644
--- a/app-mobilephone/obexd/obexd-0.21-r1.ebuild
+++ b/app-mobilephone/obexd/obexd-0.21-r2.ebuild
@@ -1,40 +1,39 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexd/obexd-0.21-r1.ebuild,v 1.1 2010/02/19 13:26:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexd/obexd-0.21-r2.ebuild,v 1.1 2010/02/19 18:56:19 pacho Exp $
EAPI="2"
+inherit eutils autotools
+
DESCRIPTION="OBEX Server and Client"
HOMEPAGE="http://www.bluez.org/"
SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-#IUSE="debug eds -server"
-# 'eds' USE flag disabled until upstream fixes bug 305063
-IUSE="debug -server"
+IUSE="debug -eds -server"
-RDEPEND="net-wireless/bluez
+RDEPEND="eds? ( gnome-extra/evolution-data-server )
+ net-wireless/bluez
>=dev-libs/openobex-1.4
dev-libs/glib:2
sys-apps/dbus
server? ( !app-mobilephone/obex-data-server )"
-# eds? ( gnome-extra/evolution-data-server )
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_configure.patch"
+ eautoreconf
+}
+
src_configure() {
-# local myconf
-# if use eds; then
-# myconf="${myconf} --with-phonebook=ebook"
-# else
-# myconf="${myconf} --with-phonebook=dummy"
-# fi
econf \
$(use_enable debug) \
+ $(use_with eds phonebook ebook) \
$(use_enable server)
-# ${myconf}
}
src_install() {