summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-08-29 06:23:33 +0000
committerAlin Năstac <mrness@gentoo.org>2005-08-29 06:23:33 +0000
commit61ed28171a913ba5fb64fda594dfb0378c9b6157 (patch)
tree15757612296a93a504931f8c64954c1406279bb4 /app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild
parentx86 (diff)
downloadgentoo-2-61ed28171a913ba5fb64fda594dfb0378c9b6157.tar.gz
gentoo-2-61ed28171a913ba5fb64fda594dfb0378c9b6157.tar.bz2
gentoo-2-61ed28171a913ba5fb64fda594dfb0378c9b6157.zip
fix lib path for smsd database modules (#104050)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild')
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild b/app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild
new file mode 100644
index 000000000000..4701b243529a
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.7-r2.ebuild,v 1.1 2005/08/29 06:23:33 mrness Exp $
+
+inherit eutils flag-o-matic linux-info
+
+DESCRIPTION="a client that plugs into your handphone"
+HOMEPAGE="http://www.gnokii.org/"
+SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls X bluetooth irda sms postgres mysql"
+
+RDEPEND="X? ( =x11-libs/gtk+-1.2* )
+ bluetooth? ( net-wireless/bluez-libs )
+ sms? ( >=dev-libs/glib-2
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+
+CONFIG_CHECK="UNIX98_PTYS"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-smsd-glib2.patch
+}
+
+src_compile() {
+ append-ldflags "-Wl,-z,now" #avoid QA notices
+
+ autoconf && econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --disable-debug \
+ --disable-xdebug \
+ --disable-rlpdebug \
+ --enable-security \
+ --disable-unix98test \
+ || die "configure failed"
+
+ if use sms ; then
+ cd ${S}/smsd
+
+ if use postgres; then
+ emake libpq.la || die "smsd make failed"
+ elif use mysql; then
+ emake libmysql.la || die "smsd make failed"
+ else
+ emake libfile.la || die "smsd make failed"
+ fi
+ fi
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' ${D}/etc/gnokiirc
+
+ doman Docs/man/*
+ dodir /usr/share/doc/${PF}
+ cp -r Docs/sample ${D}/usr/share/doc/${PF}/sample
+ cp -r Docs/protocol ${D}/usr/share/doc/${PF}/protocol
+ rm -rf Docs/man Docs/sample Docs/protocol
+ dodoc Docs/*
+
+ # only one file needs suid root to make a psuedo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use sms; then
+ cd ${S}/smsd
+
+ einstall || die "smsd make install failed"
+ fi
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}
+
+pkg_postinst() {
+ einfo "gnokii does not need it's own group anymore."
+ einfo "Make sure the user that runs gnokii has read/write access to the device"
+ einfo "which your phone is connected to. eg. chown <user> /dev/ttyS0"
+}