summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-05 06:19:02 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-05 06:19:02 +0000
commitc307ebc7896a71d9a429850d92fd2e5a19324a83 (patch)
tree21723ccb779091fce9450b9dc0f6d742ff68a041 /app-mobilephone/gammu
parentFix compile error when built without threads support (#283475). (diff)
downloadgentoo-2-c307ebc7896a71d9a429850d92fd2e5a19324a83.tar.gz
gentoo-2-c307ebc7896a71d9a429850d92fd2e5a19324a83.tar.bz2
gentoo-2-c307ebc7896a71d9a429850d92fd2e5a19324a83.zip
Add python USE flag (#283671). Version bump (#283670).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/ChangeLog9
-rw-r--r--app-mobilephone/gammu/files/gammu-1.26.0-skip-locktest.patch12
-rw-r--r--app-mobilephone/gammu/gammu-1.25.0.ebuild11
-rw-r--r--app-mobilephone/gammu/gammu-1.26.0.ebuild (renamed from app-mobilephone/gammu/gammu-1.24.0-r1.ebuild)13
4 files changed, 36 insertions, 9 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 4f7d1500259a..2dc9ccafd138 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.71 2009/08/16 08:05:49 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.72 2009/09/05 06:19:02 mrness Exp $
+
+*gammu-1.26.0 (05 Sep 2009)
+
+ 05 Sep 2009; Alin Năstac <mrness@gentoo.org>
+ +files/gammu-1.26.0-skip-locktest.patch, -gammu-1.24.0-r1.ebuild,
+ gammu-1.25.0.ebuild, +gammu-1.26.0.ebuild:
+ Add python USE flag (#283671). Version bump (#283670).
*gammu-1.25.0 (16 Aug 2009)
diff --git a/app-mobilephone/gammu/files/gammu-1.26.0-skip-locktest.patch b/app-mobilephone/gammu/files/gammu-1.26.0-skip-locktest.patch
new file mode 100644
index 000000000000..345aa0a0005b
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.26.0-skip-locktest.patch
@@ -0,0 +1,12 @@
+diff -Nru gammu-1.26.0.orig/tests/CMakeLists.txt gammu-1.26.0/tests/CMakeLists.txt
+--- gammu-1.26.0.orig/tests/CMakeLists.txt 2009-09-04 10:56:25.000000000 +0200
++++ gammu-1.26.0/tests/CMakeLists.txt 2009-09-05 07:46:58.000000000 +0200
+@@ -739,7 +739,7 @@
+
+ # Test for locking, only on !WIN32 and if we can write to lock dir
+ if (NOT WIN32)
+- execute_process(COMMAND test -w /var/lock/ RESULT_VARIABLE VAR_LOCK_WRITABLE)
++ set (VAR_LOCK_WRITABLE 1)
+ if (VAR_LOCK_WRITABLE EQUAL 0)
+ add_executable(locking locking.c)
+ target_link_libraries(locking libGammu)
diff --git a/app-mobilephone/gammu/gammu-1.25.0.ebuild b/app-mobilephone/gammu/gammu-1.25.0.ebuild
index 3eaf32452c11..603bee8763e8 100644
--- a/app-mobilephone/gammu/gammu-1.25.0.ebuild
+++ b/app-mobilephone/gammu/gammu-1.25.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.25.0.ebuild,v 1.1 2009/08/16 08:05:49 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.25.0.ebuild,v 1.2 2009/09/05 06:19:02 mrness Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl debug bluetooth irda mysql postgres dbi nls usb"
+IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
RDEPEND="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
curl? ( net-misc/curl )
@@ -61,13 +61,16 @@ src_configure() {
$(cmake-utils_use_with irda IRDA) \
$(cmake-utils_use_with curl CURL) \
$(cmake-utils_use_with usb USB) \
+ $(cmake-utils_use_with python PYTHON) \
$(cmake-utils_use_with mysql MySQL) \
$(cmake-utils_use_with postgres Postgres) \
$(cmake-utils_use_with dbi LibDBI) \
$(cmake-utils_use_with nls GettextLibs) \
$(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF} \
- -DBUILD_PYTHON=/usr/bin/python"
+ -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
+ if use python; then
+ mycmakeargs="${mycmakearg} -DBUILD_PYTHON=/usr/bin/python"
+ fi
cmake-utils_src_configure
}
diff --git a/app-mobilephone/gammu/gammu-1.24.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.26.0.ebuild
index 60eb0030f76c..f759b23ea189 100644
--- a/app-mobilephone/gammu/gammu-1.24.0-r1.ebuild
+++ b/app-mobilephone/gammu/gammu-1.26.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.24.0-r1.ebuild,v 1.2 2009/06/15 21:24:16 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.26.0.ebuild,v 1.1 2009/09/05 06:19:02 mrness Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="curl debug bluetooth irda mysql postgres dbi nls usb"
+IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
RDEPEND="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
curl? ( net-misc/curl )
@@ -36,6 +36,8 @@ MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-skip-locktest.patch
+
local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
@@ -59,13 +61,16 @@ src_configure() {
$(cmake-utils_use_with irda IRDA) \
$(cmake-utils_use_with curl CURL) \
$(cmake-utils_use_with usb USB) \
+ $(cmake-utils_use_with python PYTHON) \
$(cmake-utils_use_with mysql MySQL) \
$(cmake-utils_use_with postgres Postgres) \
$(cmake-utils_use_with dbi LibDBI) \
$(cmake-utils_use_with nls GettextLibs) \
$(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF} \
- -DBUILD_PYTHON=/usr/bin/python"
+ -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
+ if use python; then
+ mycmakeargs="${mycmakearg} -DBUILD_PYTHON=/usr/bin/python"
+ fi
cmake-utils_src_configure
}