summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-20 23:11:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-20 23:11:41 +0000
commitfd1ce6d6e4b9db3cc4be7c0f45e410fee1fd6756 (patch)
tree93beb2f0b34f9c0482b11c404eddf22bb39a29a2 /app-misc
parentUpdate to 1.3.1_rc1 to fix security bug #158122. (diff)
downloadgentoo-2-fd1ce6d6e4b9db3cc4be7c0f45e410fee1fd6756.tar.gz
gentoo-2-fd1ce6d6e4b9db3cc4be7c0f45e410fee1fd6756.tar.bz2
gentoo-2-fd1ce6d6e4b9db3cc4be7c0f45e410fee1fd6756.zip
touchups
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/figlet/figlet-221-r1.ebuild39
1 files changed, 19 insertions, 20 deletions
diff --git a/app-misc/figlet/figlet-221-r1.ebuild b/app-misc/figlet/figlet-221-r1.ebuild
index 37f08adda687..5bf0e4f29b0d 100644
--- a/app-misc/figlet/figlet-221-r1.ebuild
+++ b/app-misc/figlet/figlet-221-r1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-221-r1.ebuild,v 1.12 2006/06/16 20:40:26 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-221-r1.ebuild,v 1.13 2006/12/20 23:11:41 mr_bones_ Exp $
inherit eutils bash-completion
MY_P=${P/-/}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="program for making large letters out of ordinary text"
HOMEPAGE="http://www.figlet.org/"
# Bug 35339 - add more fonts to figlet ebuild
@@ -20,23 +19,23 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- cp ${WORKDIR}/contributed/C64-fonts/*.flf fonts/
- cp ${WORKDIR}/contributed/bdffonts/*.flf fonts/
- cp ${WORKDIR}/ms-dos/*.flf fonts/
- cp ${WORKDIR}/contributed/*.flf fonts/
+ cp "${WORKDIR}"/contributed/C64-fonts/*.flf fonts/ || die
+ cp "${WORKDIR}"/contributed/bdffonts/*.flf fonts/ || die
+ cp "${WORKDIR}"/ms-dos/*.flf fonts/ || die
+ cp "${WORKDIR}"/contributed/*.flf fonts/ || die
- epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-gentoo.diff
sed -i \
- -e "s/CFLAGS = -g/CFLAGS = ${CFLAGS}/g" Makefile || \
- die "sed Makefile failed"
+ -e "s/CFLAGS = -g/CFLAGS = ${CFLAGS}/g" Makefile \
+ || die "sed failed"
}
src_compile() {
@@ -45,14 +44,14 @@ src_compile() {
}
src_install() {
- dodir /usr/bin /usr/share/man/man6
+ dodir /usr/bin /usr/share/man/man6 || die "dodir failed"
chmod +x figlist showfigfonts
- make \
- DESTDIR=${D}/usr/bin \
- MANDIR=${D}/usr/share/man/man6 \
- DEFAULTFONTDIR=${D}/usr/share/figlet \
+ emake \
+ DESTDIR="${D}"/usr/bin \
+ MANDIR="${D}"/usr/share/man/man6 \
+ DEFAULTFONTDIR="${D}"/usr/share/figlet \
install || die "make install failed"
- dodoc README figfont.txt || die "dodoc failed"
- dobashcompletion ${FILESDIR}/figlet.bashcomp
+ dodoc README figfont.txt
+ dobashcompletion "${FILESDIR}"/figlet.bashcomp
}