summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-22 12:02:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-22 12:02:41 +0000
commitf2bf32c0fe8a38f4feae72864ac96474f0f5a967 (patch)
tree073c656d290675e5e13f1cb14932ed1e4eb95ec9 /app-misc
parentx86 stable wrt security bug #348766 (diff)
downloadgentoo-2-f2bf32c0fe8a38f4feae72864ac96474f0f5a967.tar.gz
gentoo-2-f2bf32c0fe8a38f4feae72864ac96474f0f5a967.tar.bz2
gentoo-2-f2bf32c0fe8a38f4feae72864ac96474f0f5a967.zip
Initial commit of utimer application. Thanks to Kfir Lavi <lavi.kfir@gmail.com>. Bug #348856
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/utimer/ChangeLog11
-rw-r--r--app-misc/utimer/metadata.xml12
-rw-r--r--app-misc/utimer/utimer-0.4.ebuild33
3 files changed, 56 insertions, 0 deletions
diff --git a/app-misc/utimer/ChangeLog b/app-misc/utimer/ChangeLog
new file mode 100644
index 000000000000..5c97a9419222
--- /dev/null
+++ b/app-misc/utimer/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-misc/utimer
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/utimer/ChangeLog,v 1.1 2010/12/22 12:02:41 hwoarang Exp $
+
+*utimer-0.4 (22 Dec 2010)
+
+ 22 Dec 2010; Markos Chandras <hwoarang@gentoo.org> +utimer-0.4.ebuild,
+ +metadata.xml:
+ Initial commit of utimer application. Thanks to Kfir Lavi
+ <lavi.kfir@gmail.com>. Bug #348856
+
diff --git a/app-misc/utimer/metadata.xml b/app-misc/utimer/metadata.xml
new file mode 100644
index 000000000000..87afd6e36004
--- /dev/null
+++ b/app-misc/utimer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-misc/utimer/utimer-0.4.ebuild b/app-misc/utimer/utimer-0.4.ebuild
new file mode 100644
index 000000000000..8d4bb2b54bc2
--- /dev/null
+++ b/app-misc/utimer/utimer-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/utimer/utimer-0.4.ebuild,v 1.1 2010/12/22 12:02:41 hwoarang Exp $
+
+EAPI=2
+
+DESCRIPTION="A command line timer and stopwatch"
+HOMEPAGE="http://utimer.codealpha.net/utimer"
+SRC_URI="http://utimer.codealpha.net/dl.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+DEPEND=">=dev-libs/glib-2.18.2
+ >=dev-util/intltool-0.40.5"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=
+ if use debug; then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+ econf ${myconf} $(use_enable nls)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "failed to install"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}