summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-25 21:02:07 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-25 21:02:07 +0000
commite4f15fa352e2b27f0d998235b5f7ac48d17cb367 (patch)
tree2c05da3b0daf3b2e688d1c589f7071ef2f806517 /app-misc
parentRemove old version. (diff)
downloadgentoo-2-e4f15fa352e2b27f0d998235b5f7ac48d17cb367.tar.gz
gentoo-2-e4f15fa352e2b27f0d998235b5f7ac48d17cb367.tar.bz2
gentoo-2-e4f15fa352e2b27f0d998235b5f7ac48d17cb367.zip
Version bump (bug #346405)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/golly/ChangeLog8
-rw-r--r--app-misc/golly/golly-2.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-misc/golly/ChangeLog b/app-misc/golly/ChangeLog
index 887ecde549a6..85b5f5bd47b5 100644
--- a/app-misc/golly/ChangeLog
+++ b/app-misc/golly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/golly
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.4 2010/11/01 15:33:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/ChangeLog,v 1.5 2010/11/25 21:02:07 xmw Exp $
+
+*golly-2.2 (25 Nov 2010)
+
+ 25 Nov 2010; Michael Weber <xmw@gentoo.org> +golly-2.2.ebuild:
+ Version bump, thanks to Maks Verver <maksverver@geocities.com> for his report
+ and ebuild on bug #346405.
01 Nov 2010; Christian Faulhammer <fauli@gentoo.org> golly-2.1-r1.ebuild:
stable x86, bug 342889
diff --git a/app-misc/golly/golly-2.2.ebuild b/app-misc/golly/golly-2.2.ebuild
new file mode 100644
index 000000000000..5c8f30588a57
--- /dev/null
+++ b/app-misc/golly/golly-2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/golly/golly-2.2.ebuild,v 1.1 2010/11/25 21:02:07 xmw Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+WX_GTK_VER=2.8
+
+inherit eutils python wxwidgets
+
+MY_P=${P}-src
+DESCRIPTION="A simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ --with-perl-shlib="libperl.so" \
+ --with-python-shlib="$(python_get_library)"
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install || die
+ dodoc README
+}