summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-24 15:12:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-24 15:12:17 +0000
commite02c17a48a8f63e7edd6d595f8eb582afbfd100f (patch)
treebe5dffd16935b992deaa9fd667c2711199c058da /app-misc
parentRemove old (diff)
downloadgentoo-2-e02c17a48a8f63e7edd6d595f8eb582afbfd100f.tar.gz
gentoo-2-e02c17a48a8f63e7edd6d595f8eb582afbfd100f.tar.bz2
gentoo-2-e02c17a48a8f63e7edd6d595f8eb582afbfd100f.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ledit/ChangeLog7
-rw-r--r--app-misc/ledit/ledit-2.02.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index 8e35a19d30a0..289c51c2c013 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ledit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.30 2010/11/17 23:06:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.31 2010/11/24 15:12:17 aballier Exp $
+
+*ledit-2.02.1 (24 Nov 2010)
+
+ 24 Nov 2010; Alexis Ballier <aballier@gentoo.org> +ledit-2.02.1.ebuild:
+ version bump
*ledit-2.02 (17 Nov 2010)
diff --git a/app-misc/ledit/ledit-2.02.1.ebuild b/app-misc/ledit/ledit-2.02.1.ebuild
new file mode 100644
index 000000000000..931c872c807c
--- /dev/null
+++ b/app-misc/ledit/ledit-2.02.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.02.1.ebuild,v 1.1 2010/11/24 15:12:17 aballier Exp $
+
+EAPI=2
+inherit eutils
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09[ocamlopt?]
+ dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit || die
+ else
+ newbin ledit.out ledit || die
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}