summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2003-03-02 16:31:28 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2003-03-02 16:31:28 +0000
commitd6f3f526b127c90bd1d7e9fef29f9b46cd5fca7a (patch)
tree89257c998e98a846e5493b564f89a487b4338fa1 /app-misc
parentReplaced $ARCH with $(ARCH) (diff)
downloadgentoo-2-d6f3f526b127c90bd1d7e9fef29f9b46cd5fca7a.tar.gz
gentoo-2-d6f3f526b127c90bd1d7e9fef29f9b46cd5fca7a.tar.bz2
gentoo-2-d6f3f526b127c90bd1d7e9fef29f9b46cd5fca7a.zip
First relase
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xhkeys/ChangeLog10
-rw-r--r--app-misc/xhkeys/files/digest-xhkeys-1.0.01
-rw-r--r--app-misc/xhkeys/files/xhkeys16
-rw-r--r--app-misc/xhkeys/xhkeys-1.0.0.ebuild35
4 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/xhkeys/ChangeLog b/app-misc/xhkeys/ChangeLog
new file mode 100644
index 000000000000..8d66a31109d2
--- /dev/null
+++ b/app-misc/xhkeys/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/win4lin
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xhkeys/ChangeLog,v 1.1 2003/03/02 16:31:28 bass Exp $
+
+*xhkeys-1.0.0 (02 Mar 2003)
+
+ 02 Mar 2003; J.Alberto Suárez L. <bass@gentoo.org> xhkeys-1.0.0.ebuild:
+ First relase
+
+
diff --git a/app-misc/xhkeys/files/digest-xhkeys-1.0.0 b/app-misc/xhkeys/files/digest-xhkeys-1.0.0
new file mode 100644
index 000000000000..89da43cf225e
--- /dev/null
+++ b/app-misc/xhkeys/files/digest-xhkeys-1.0.0
@@ -0,0 +1 @@
+MD5 aa5fbb575716bb81208924a0e72d277c xhkeys-1.0.0.tar.gz 52264
diff --git a/app-misc/xhkeys/files/xhkeys b/app-misc/xhkeys/files/xhkeys
new file mode 100644
index 000000000000..c07f536bccce
--- /dev/null
+++ b/app-misc/xhkeys/files/xhkeys
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xhkeys/files/xhkeys,v 1.1 2003/03/02 16:31:28 bass Exp $
+
+start() {
+ ebegin "Starting xhkeys"
+ start-stop-daemon --start --quiet --exec /usr/bin/xhkeys
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xhkeys"
+ start-stop-daemon --stop --quiet --exec /usr/bin/xhkeys
+ eend $?
+}
diff --git a/app-misc/xhkeys/xhkeys-1.0.0.ebuild b/app-misc/xhkeys/xhkeys-1.0.0.ebuild
new file mode 100644
index 000000000000..d86a38b4a0bf
--- /dev/null
+++ b/app-misc/xhkeys/xhkeys-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xhkeys/xhkeys-1.0.0.ebuild,v 1.1 2003/03/02 16:31:28 bass Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The application allows to assign a particular action to any key or key combination."
+SRC_URI="http://www.geocities.com/wmalms/${P}.tar.gz"
+HOMEPAGE="http://www.geocities.com/wmalms"
+LICENSE="GPL-2"
+DEPEND="x11-base/xfree"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ dobin xhkeys xhkconf
+# exeinto /etc/init.d/
+# doexe ${FILESDIR}/xhkeys
+
+ dodoc README VERSION
+}