summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-05-30 17:27:45 +0000
committerDaniel Drake <dsd@gentoo.org>2006-05-30 17:27:45 +0000
commitd0f12edc372c4e55baa10071b56d539c65627fd8 (patch)
tree50fff20ba93d127f5fa54edbfd2dc0f18929811c /app-misc
parentRemoved tigger from metadata (#20799) (diff)
downloadgentoo-2-d0f12edc372c4e55baa10071b56d539c65627fd8.tar.gz
gentoo-2-d0f12edc372c4e55baa10071b56d539c65627fd8.tar.bz2
gentoo-2-d0f12edc372c4e55baa10071b56d539c65627fd8.zip
Version bump thanks to Ernst Herzberg in bug #132619
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/klive/ChangeLog7
-rw-r--r--app-misc/klive/files/digest-klive-0.162
-rw-r--r--app-misc/klive/files/digest-klive-0.233
-rw-r--r--app-misc/klive/klive-0.23.ebuild59
4 files changed, 70 insertions, 1 deletions
diff --git a/app-misc/klive/ChangeLog b/app-misc/klive/ChangeLog
index 034159a27a90..24c596fd560a 100644
--- a/app-misc/klive/ChangeLog
+++ b/app-misc/klive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/klive
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/klive/ChangeLog,v 1.12 2006/04/20 05:13:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/klive/ChangeLog,v 1.13 2006/05/30 17:27:45 dsd Exp $
+
+*klive-0.23 (30 May 2006)
+
+ 30 May 2006; Daniel Drake <dsd@gentoo.org> +klive-0.23.ebuild:
+ Version bump thanks to Ernst Herzberg in bug #132619
20 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> klive-0.16.ebuild:
Run enewuser in pkg_setup rather than src_install. See bug #124680 for more
diff --git a/app-misc/klive/files/digest-klive-0.16 b/app-misc/klive/files/digest-klive-0.16
index 084679403bbf..71e3b98c8390 100644
--- a/app-misc/klive/files/digest-klive-0.16
+++ b/app-misc/klive/files/digest-klive-0.16
@@ -1 +1,3 @@
MD5 7f341d60f6f997a36a73e6881c1ccd87 klive-0.16.tar.bz2 25814
+RMD160 acefe424839e4ded4435eef0861a3673ad9e0757 klive-0.16.tar.bz2 25814
+SHA256 4b711bbed35125d8d53345283645bf082dfa78cec01f65b4e86af5358538ab51 klive-0.16.tar.bz2 25814
diff --git a/app-misc/klive/files/digest-klive-0.23 b/app-misc/klive/files/digest-klive-0.23
new file mode 100644
index 000000000000..4e0a488debe3
--- /dev/null
+++ b/app-misc/klive/files/digest-klive-0.23
@@ -0,0 +1,3 @@
+MD5 69a09a81b75de5ba92038a952da4906f klive-0.23.tar.bz2 26829
+RMD160 b59339579aa544480e6f3df9681f05b7cd80029c klive-0.23.tar.bz2 26829
+SHA256 40835936fd22fbf440ad000e6097508fe5fce933ba64e25fe2341080834c51b5 klive-0.23.tar.bz2 26829
diff --git a/app-misc/klive/klive-0.23.ebuild b/app-misc/klive/klive-0.23.ebuild
new file mode 100644
index 000000000000..2740cdf12a52
--- /dev/null
+++ b/app-misc/klive/klive-0.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/klive/klive-0.23.ebuild,v 1.1 2006/05/30 17:27:45 dsd Exp $
+
+inherit eutils
+
+DESCRIPTION="Linux Kernel Live Usage Monitor"
+HOMEPAGE="http://klive.cpushare.com/"
+SRC_URI="http://klive.cpushare.com/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ >=dev-python/twisted-2.0.0"
+RDEPEND="sys-apps/pciutils"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ enewuser klive -1 /bin/bash
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins client/klive.tac
+ newinitd ${FILESDIR}/klive.init.d klive || die "init.d failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ echo
+
+ einfo "To start klive, use the init script, e.g.:"
+ einfo " # /etc/init.d/klive start"
+ echo
+
+ einfo "You should add klive to your default runlevel so that it will be"
+ einfo "started on on every bootup, e.g.:"
+ einfo " # rc-update add klive default"
+ echo
+
+ ewarn "klive periodically submits basic information about the configuration of"
+ ewarn "your running kernel to a 3rd-party server which is NOT controlled by"
+ ewarn "Gentoo. This data is probably privately logged against your IP address."
+ echo
+
+ einfo "The data submitted is used to generate basic statistics which provide"
+ einfo "insight as to how widely tested a particular kernel version is."
+ einfo "These statistics are publically accessible at http://klive.cpushare.com"
+ echo
+
+ ewarn "If you have privacy/security concerns about the submission of this data"
+ ewarn "and/or its public availability, unmerge this package now."
+ echo
+}
+