summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-01-15 16:18:16 +0000
committerAron Griffis <agriffis@gentoo.org>2003-01-15 16:18:16 +0000
commitcec481f6d93e59f53d36630d33f033dd3d8d438f (patch)
tree7065c6849a72e844169a084a5a3243c31b635cee /app-misc
parentChanged <CATEGORY>/<PACKAGE_NAME> to app-text/cook (diff)
downloadgentoo-2-cec481f6d93e59f53d36630d33f033dd3d8d438f.tar.gz
gentoo-2-cec481f6d93e59f53d36630d33f033dd3d8d438f.tar.bz2
gentoo-2-cec481f6d93e59f53d36630d33f033dd3d8d438f.zip
Fix bug 12683
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/screen/ChangeLog6
-rw-r--r--app-misc/screen/screen-3.9.13-r3.ebuild17
2 files changed, 21 insertions, 2 deletions
diff --git a/app-misc/screen/ChangeLog b/app-misc/screen/ChangeLog
index 21d0aa6a0a2c..99216a06b440 100644
--- a/app-misc/screen/ChangeLog
+++ b/app-misc/screen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/screen
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.21 2002/12/20 16:48:35 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.22 2003/01/15 16:18:16 agriffis Exp $
+
+ 15 Jan 2003; Aron Griffis <agriffis@gentoo.org> screen-3.9.13-r3.ebuild :
+ Fixup term.h to fix bug 12683. Believe this is an upstream problem in
+ screen, but no doubt it will be ironed out eventually.
*screen-3.9.13-r3 (20 Dec 2002)
diff --git a/app-misc/screen/screen-3.9.13-r3.ebuild b/app-misc/screen/screen-3.9.13-r3.ebuild
index 601eb4fe2935..034d0b7ce14f 100644
--- a/app-misc/screen/screen-3.9.13-r3.ebuild
+++ b/app-misc/screen/screen-3.9.13-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-3.9.13-r3.ebuild,v 1.1 2002/12/20 16:48:35 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-3.9.13-r3.ebuild,v 1.2 2003/01/15 16:18:16 agriffis Exp $
inherit flag-o-matic
@@ -44,6 +44,21 @@ src_compile() {
--with-sys-screenrc=/etc/screenrc \
--enable-rxvt_osc ${myconf}
+ # Fix bug 12683 by fixing up term.h (remove dups and add missing).
+ # This is really an upstream problem in screen, I think.
+ # (15 Jan 2003 agriffis)
+ make term.h || die "Failed making term.h"
+ mv term.h term.h.old
+ awk '/^#define/ { if (defs[$2]) next; defs[$2] = $3 }
+ { print }
+ END { for (d in defs) {
+ if (d !~ /_C../) continue;
+ d2 = gensub(/C/, "", 1, d);
+ if (d2 in defs) continue;
+ print "#define " d2 " " defs[d]
+ }
+ }' term.h.old > term.h || die "Failed to fix term.h"
+
emake || die "Failed to compile"
}