summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-08-15 07:05:37 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-08-15 07:05:37 +0000
commitc78e62e423ebac506a0a10fc2d35587970c68b55 (patch)
tree138734cc94fc845da91fe17f0d772891d76076ba /app-misc
parentupdated to 2.2.3.2 (diff)
downloadgentoo-2-c78e62e423ebac506a0a10fc2d35587970c68b55.tar.gz
gentoo-2-c78e62e423ebac506a0a10fc2d35587970c68b55.tar.bz2
gentoo-2-c78e62e423ebac506a0a10fc2d35587970c68b55.zip
bbkeysconf for new bbkeys
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/bbkeysconf/bbkeysconf-1.3.ebuild26
-rw-r--r--app-misc/bbkeysconf/files/digest-bbkeysconf-1.31
2 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/bbkeysconf/bbkeysconf-1.3.ebuild b/app-misc/bbkeysconf/bbkeysconf-1.3.ebuild
new file mode 100644
index 000000000000..0f012f7a40e3
--- /dev/null
+++ b/app-misc/bbkeysconf/bbkeysconf-1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Configure bbkeys"
+SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${A}"
+HOMEPAGE="http://movingparts.thelinuxcommunity.org"
+
+DEPEND=">=x11-libs/qt-x11-2.3.0
+ >=x11-wm/blackbox-0.61
+ >=x11-wm/bbkeys-0.8.2"
+
+src_compile() {
+
+ local qtdir=${QTDIR}
+ try make MOC=${qtdir}/bin/moc CXXFLAGS="-g -I${qtdir}/include ${CXXFLAGS}" LIBS="-L${qtdir}/lib -L/usr/X11R6/lib -lqt -lX11"
+}
+
+src_install () {
+
+ into /usr/X11R6
+ dobin bbkeysconf
+}
+
diff --git a/app-misc/bbkeysconf/files/digest-bbkeysconf-1.3 b/app-misc/bbkeysconf/files/digest-bbkeysconf-1.3
new file mode 100644
index 000000000000..a883842b923a
--- /dev/null
+++ b/app-misc/bbkeysconf/files/digest-bbkeysconf-1.3
@@ -0,0 +1 @@
+MD5 23cb901110dc398c6972f0849714cecb bbkeysconf-1.3.tar.gz