summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-24 21:59:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-24 21:59:33 +0000
commitb898e3b2a31bbdeafea7204f0c1fd410144c1124 (patch)
tree7b755860b6159e1ad7b228e76907104074c8cabf /app-misc
parentStable for HPPA (bug #271105). (diff)
downloadgentoo-2-b898e3b2a31bbdeafea7204f0c1fd410144c1124.tar.gz
gentoo-2-b898e3b2a31bbdeafea7204f0c1fd410144c1124.tar.bz2
gentoo-2-b898e3b2a31bbdeafea7204f0c1fd410144c1124.zip
Fix encoding of some files (bug #230832).
(Portage version: 13625-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/ChangeLog8
-rw-r--r--app-misc/mc/mc-4.6.2_pre1.ebuild29
2 files changed, 33 insertions, 4 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 4a8a60647da4..94020829f364 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/mc
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.145 2008/11/24 17:55:35 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.146 2009/05/24 21:59:33 arfrever Exp $
+
+ 24 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mc-4.6.2_pre1.ebuild:
+ Fix encoding of some files (bug #230832).
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml, mc-4.6.2_pre1.ebuild:
Rename my old e-mail drac at gentoo.org to ssuominen at gentoo.org. Move
diff --git a/app-misc/mc/mc-4.6.2_pre1.ebuild b/app-misc/mc/mc-4.6.2_pre1.ebuild
index 7bd8dfa44c21..b82017822d52 100644
--- a/app-misc/mc/mc-4.6.2_pre1.ebuild
+++ b/app-misc/mc/mc-4.6.2_pre1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.2_pre1.ebuild,v 1.7 2008/11/24 17:55:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.2_pre1.ebuild,v 1.8 2009/05/24 21:59:33 arfrever Exp $
EAPI=1
@@ -50,6 +50,31 @@ src_unpack() {
sed -i -e "s:^\(cons_saver_LDADD = .*\):\1 -Wl,-z,now:" \
src/Makefile.in || die "sed failed."
+ if use unicode; then
+ local conversion_table=(
+ "cs ISO-8859-2"
+ "es ISO-8859-1"
+ "hu ISO-8859-2"
+ "nl ISO-8859-1"
+ "pl ISO-8859-2"
+ "ru KOI8-R"
+ "sr ISO-8859-5"
+ "uk KOI8-U"
+ )
+ local element
+ for element in "${conversion_table[@]}"; do
+ local lingua="${element% *}"
+ local old_encoding="${element#* }"
+ local file
+ for file in "doc/${lingua}/xnc.hlp" "lib/mc.hint.${lingua}" "lib/mc.menu.${lingua}"; do
+ if [[ -f "${file}" ]]; then
+ mv "${file}" "${file}.${old_encoding}"
+ iconv -f ${old_encoding} -t UTF-8 -o "${file}" "${file}.${old_encoding}" || die "iconv ${file} failed"
+ fi
+ done
+ done
+ fi
+
# docs try to run the files it just built while trying convert .1 to .hlp files.
# this will never work for cross compiles, so we simply don't make docs.
if tc-is-cross-compiler; then