summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:35:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:35:06 +0000
commita7f952dc2651134533e6475a8f736e854d242d51 (patch)
tree297ff040bd9ee8c317b4da2f0e98e9f5b690ef68 /app-misc
parentQA - fix use invocation (diff)
downloadgentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.tar.gz
gentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.tar.bz2
gentoo-2-a7f952dc2651134533e6475a8f736e854d242d51.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/colortail/colortail-0.3.0-r2.ebuild24
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5.ebuild8
-rw-r--r--app-misc/delay/delay-1.6.ebuild15
-rw-r--r--app-misc/devtodo/devtodo-0.1.17.ebuild15
-rw-r--r--app-misc/digitemp/digitemp-3.2.0.ebuild13
-rw-r--r--app-misc/digitemp/digitemp-3.3.1.ebuild13
-rw-r--r--app-misc/discomatic/discomatic-0.3.ebuild8
-rw-r--r--app-misc/egads/egads-0.9.5.ebuild15
-rw-r--r--app-misc/evidence/evidence-0.9.8.20040522.ebuild4
-rw-r--r--app-misc/figlet/figlet-221-r1.ebuild8
-rw-r--r--app-misc/filer/filer-0.0.5.ebuild7
-rw-r--r--app-misc/fixdos/fixdos-1.3.1.ebuild8
12 files changed, 64 insertions, 74 deletions
diff --git a/app-misc/colortail/colortail-0.3.0-r2.ebuild b/app-misc/colortail/colortail-0.3.0-r2.ebuild
index 5add8d4b7d58..dd5f9c1327fe 100644
--- a/app-misc/colortail/colortail-0.3.0-r2.ebuild
+++ b/app-misc/colortail/colortail-0.3.0-r2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r2.ebuild,v 1.11 2004/06/24 22:06:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r2.ebuild,v 1.12 2004/06/28 03:30:17 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Colortail custom colors your log files and works like tail"
-SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
HOMEPAGE="http://www.student.hk-r.se/~pt98jan/colortail.html"
+SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
-DEPEND="virtual/glibc"
-
-SLOT="0"
LICENSE="GPL-2"
-IUSE=""
+SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
+
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gcc3.patch || die "Patching failed"
+ epatch ${FILESDIR}/${P}-gcc3.patch
}
src_compile() {
@@ -25,8 +26,7 @@ src_compile() {
make || die
}
-src_install() {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc README example-conf/conf*
dodir /usr/bin/wrappers
@@ -34,8 +34,7 @@ src_install() {
}
pkg_postinst() {
- einfo
- if grep /usr/bin/wrappers /etc/profile > /dev/null
+ if grep /usr/bin/wrappers ${ROOT}/etc/profile > /dev/null
then
einfo "/etc/profile already updated for wrappers"
else
@@ -44,5 +43,4 @@ pkg_postinst() {
einfo "#Put /usr/bin/wrappers in path before /usr/bin"
einfo 'export PATH=/usr/bin/wrappers:${PATH}'
fi
- einfo
}
diff --git a/app-misc/countrycodes/countrycodes-1.0.5.ebuild b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
index 2b376eb2afb2..22f1f0958edb 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.5 2004/06/28 01:08:52 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.6 2004/06/28 03:30:35 vapier Exp $
-DESCRIPTION="An ISO 3166 country code finder."
+DESCRIPTION="An ISO 3166 country code finder"
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86 ~sparc ~mips"
IUSE=""
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
sys-apps/sed"
@@ -19,7 +19,7 @@ src_compile() {
emake -C src $MAKEOPTS CCOPTS="$CFLAGS" || die "emake failed"
}
-src_install () {
+src_install() {
dodir /usr/bin /usr/share/man/man1
make \
-C src \
diff --git a/app-misc/delay/delay-1.6.ebuild b/app-misc/delay/delay-1.6.ebuild
index 15101e89d21e..9f492a068402 100644
--- a/app-misc/delay/delay-1.6.ebuild
+++ b/app-misc/delay/delay-1.6.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/delay/delay-1.6.ebuild,v 1.10 2004/06/28 01:14:07 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/delay/delay-1.6.ebuild,v 1.11 2004/06/28 03:30:57 vapier Exp $
-DESCRIPTION="Delay is a sleeplike program that counts down the number of seconds specified on its command line."
+DESCRIPTION="sleeplike program that counts down the number of seconds specified"
HOMEPAGE="http://onegeek.org/~tom/software/delay/"
-IUSE=""
-KEYWORDS="x86 ppc ~amd64 ~sparc ~mips"
SRC_URI="http://onegeek.org/~tom/software/delay/dl/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~mips ~amd64"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
sed -i -e "s/#include <stdio.h>/&\n#include <stdlib.h>/" delay.c
@@ -22,7 +23,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc ChangeLog README COPYING INSTALL
+ dodoc ChangeLog README INSTALL
}
diff --git a/app-misc/devtodo/devtodo-0.1.17.ebuild b/app-misc/devtodo/devtodo-0.1.17.ebuild
index 0a701c1bbccf..ecfbeed2b5b0 100644
--- a/app-misc/devtodo/devtodo-0.1.17.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.17.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.17.ebuild,v 1.13 2004/06/28 01:15:52 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.17.ebuild,v 1.14 2004/06/28 03:31:19 vapier Exp $
inherit eutils gnuconfig
-IUSE=""
DESCRIPTION="A nice command line todo list for developers"
HOMEPAGE="http://devtodo.sourceforge.net/"
SRC_URI="http://devtodo.sourceforge.net/${PV}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha ~hppa mips amd64 ~ia64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha ~hppa amd64 ~ia64 s390"
+IUSE=""
DEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.1"
@@ -19,21 +19,18 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd ${S}
-
# Patch to allow compilation with gcc-3.3
epatch ${FILESDIR}/${PN}.patch
}
src_compile() {
gnuconfig_update
-
- econf \
- --sysconfdir=/etc/devtodo || die
+ econf --sysconfdir=/etc/devtodo || die
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
+ dodoc AUTHORS ChangeLog QuickStart README TODO
dodoc doc/scripts.sh doc/scripts.tcsh doc/todorc.example contrib/tdrec
}
diff --git a/app-misc/digitemp/digitemp-3.2.0.ebuild b/app-misc/digitemp/digitemp-3.2.0.ebuild
index e39047f19738..eaf04e442673 100644
--- a/app-misc/digitemp/digitemp-3.2.0.ebuild
+++ b/app-misc/digitemp/digitemp-3.2.0.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.2.0.ebuild,v 1.4 2004/06/24 22:08:19 agriffis Exp $
-
-IUSE="perl python"
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.2.0.ebuild,v 1.5 2004/06/28 03:31:40 vapier Exp $
DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="perl python"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
# default is to compile to the ds9097u. local use flag takes care of
@@ -32,8 +31,8 @@ src_compile() {
}
src_install() {
- dobin digitemp
- dodoc README COPYING FAQ TODO
+ dobin digitemp || die
+ dodoc README FAQ TODO
# method one: don't treat the examples as docs; place them somewhere else.
# then tell the user where to find this stuff. suitable alternative:
diff --git a/app-misc/digitemp/digitemp-3.3.1.ebuild b/app-misc/digitemp/digitemp-3.3.1.ebuild
index 6e78b4f6c272..d053d732d84c 100644
--- a/app-misc/digitemp/digitemp-3.3.1.ebuild
+++ b/app-misc/digitemp/digitemp-3.3.1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.3 2004/06/24 22:08:19 agriffis Exp $
-
-IUSE="perl python"
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.4 2004/06/28 03:31:40 vapier Exp $
DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="perl python"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
# default is to compile to the ds9097u. local use flag takes care of
@@ -32,8 +31,8 @@ src_compile() {
}
src_install() {
- dobin digitemp
- dodoc README COPYING FAQ TODO
+ dobin digitemp || die
+ dodoc README FAQ TODO
# method one: don't treat the examples as docs; place them somewhere else.
# then tell the user where to find this stuff. suitable alternative:
diff --git a/app-misc/discomatic/discomatic-0.3.ebuild b/app-misc/discomatic/discomatic-0.3.ebuild
index a591ad18f3e2..68cbe8afe78a 100644
--- a/app-misc/discomatic/discomatic-0.3.ebuild
+++ b/app-misc/discomatic/discomatic-0.3.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.2 2004/06/24 22:08:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.3 2004/06/28 03:31:57 vapier Exp $
inherit gnome2
-IUSE=""
-
DESCRIPTION="GTK+ CD-ROM archiving tool for mastering and burning multiple CD-ROM"
HOMEPAGE="http://discomatic.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -13,11 +11,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
RDEPEND=">=dev-libs/glib-2.2
>=x11-libs/gtk+-2.2"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README* TODO"
diff --git a/app-misc/egads/egads-0.9.5.ebuild b/app-misc/egads/egads-0.9.5.ebuild
index 50446139d890..1e856b0aeb15 100644
--- a/app-misc/egads/egads-0.9.5.ebuild
+++ b/app-misc/egads/egads-0.9.5.ebuild
@@ -1,30 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/egads-0.9.5.ebuild,v 1.3 2004/06/24 22:09:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/egads-0.9.5.ebuild,v 1.4 2004/06/28 03:32:35 vapier Exp $
-DESCRIPTION="EGADS - Entropy Gathering And Distribution System"
+DESCRIPTION="Entropy Gathering And Distribution System"
HOMEPAGE="http://www.securesoftware.com/download_${PN}.htm"
SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
-IUSE=""
KEYWORDS="x86"
-DEPEND="virtual/glibc"
+IUSE=""
+
+DEPEND="virtual/libc"
egadsdatadir=/var/run/egads
src_compile() {
econf --with-egads-datadir="${egadsdatadir}" --with-bindir=/usr/sbin || die
emake || die
-
-
}
-src_install () {
+src_install() {
keepdir ${egadsdatadir}
fperm +t ${egadsdatadir}
einstall BINDIR=${D}/usr/sbin || die
dodoc README* doc/*.txt
dohtml doc/*.html
}
-
diff --git a/app-misc/evidence/evidence-0.9.8.20040522.ebuild b/app-misc/evidence/evidence-0.9.8.20040522.ebuild
index cac1af22167d..907210bdad26 100644
--- a/app-misc/evidence/evidence-0.9.8.20040522.ebuild
+++ b/app-misc/evidence/evidence-0.9.8.20040522.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/evidence/evidence-0.9.8.20040522.ebuild,v 1.2 2004/06/24 22:10:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evidence/evidence-0.9.8.20040522.ebuild,v 1.3 2004/06/28 03:33:53 vapier Exp $
inherit enlightenment eutils flag-o-matic
@@ -20,7 +20,7 @@ DEPEND=">=dev-util/pkgconfig-0.5
truetype? ( =media-libs/freetype-2* )
kde? ( kde-base/kdelibs )
media-libs/libao
- virtual/glibc
+ virtual/libc
sys-devel/gcc
app-admin/fam
>=sys-fs/efsd-0.0.1.20031013
diff --git a/app-misc/figlet/figlet-221-r1.ebuild b/app-misc/figlet/figlet-221-r1.ebuild
index b48ebaff1395..8edfeb498682 100644
--- a/app-misc/figlet/figlet-221-r1.ebuild
+++ b/app-misc/figlet/figlet-221-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-221-r1.ebuild,v 1.4 2004/06/24 22:11:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-221-r1.ebuild,v 1.5 2004/06/28 03:34:31 vapier Exp $
inherit eutils
@@ -15,12 +15,12 @@ SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${MY_P}.tar.gz
mirror://gentoo/contributed-${P}.tar.gz
mirror://gentoo/ms-dos-${P}.tar.gz"
-KEYWORDS="x86 ppc sparc alpha mips hppa"
LICENSE="Artistic"
SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa"
IUSE=""
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
@@ -40,7 +40,7 @@ src_unpack() {
}
src_compile() {
- make clean || die "make clean failed"
+ make clean || die "make clean failed"
emake figlet || die "emake failed"
}
diff --git a/app-misc/filer/filer-0.0.5.ebuild b/app-misc/filer/filer-0.0.5.ebuild
index 8f1cbe2d33e2..7c2a39b47c0a 100644
--- a/app-misc/filer/filer-0.0.5.ebuild
+++ b/app-misc/filer/filer-0.0.5.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/filer/filer-0.0.5.ebuild,v 1.2 2004/06/24 22:11:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/filer/filer-0.0.5.ebuild,v 1.3 2004/06/28 03:34:49 vapier Exp $
DESCRIPTION="Small file-manager written in perl"
HOMEPAGE="http://public.rz.fh-wolfenbuettel.de/~luedickj/"
SRC_URI="http://public.rz.fh-wolfenbuettel.de/~luedickj/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
@@ -21,9 +22,7 @@ DEPEND="dev-lang/perl
S=${WORKDIR}/${PN}
src_install() {
- dobin filer.pl
- dodoc COPYING
+ dobin filer.pl || die
dodir /usr/lib/filer
cp -R filer.glade filer.gladep Filer icons lib.pl ${D}/usr/lib/filer
}
-
diff --git a/app-misc/fixdos/fixdos-1.3.1.ebuild b/app-misc/fixdos/fixdos-1.3.1.ebuild
index d4467b6e77b0..e72b64e33805 100644
--- a/app-misc/fixdos/fixdos-1.3.1.ebuild
+++ b/app-misc/fixdos/fixdos-1.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fixdos/fixdos-1.3.1.ebuild,v 1.10 2004/06/24 22:11:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fixdos/fixdos-1.3.1.ebuild,v 1.11 2004/06/28 03:35:06 vapier Exp $
inherit eutils
-DESCRIPTION="Set of utilities such as crlf which converts files between UNIX and DOS newlines."
+DESCRIPTION="Set of utilities such as crlf which converts files between UNIX and DOS newlines"
HOMEPAGE="http://e.co.za/marius/"
SRC_URI="http://e.co.za/marius/downloads/misc/fixDos-${PV}.tar.gz"
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S=${WORKDIR}/fixDos-${PV}
@@ -30,6 +30,6 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make INSTALLDIR=${D}/usr/bin install || die
}