summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-17 14:54:27 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-17 14:54:27 +0000
commita592a04e4c1c47272596f037083268d01a062d0b (patch)
tree0d6cd780b8174636962366faf09c2c1a130b6f96 /app-misc
parentRun checkpath on the directory itself, not its parent. (diff)
downloadgentoo-2-a592a04e4c1c47272596f037083268d01a062d0b.tar.gz
gentoo-2-a592a04e4c1c47272596f037083268d01a062d0b.tar.bz2
gentoo-2-a592a04e4c1c47272596f037083268d01a062d0b.zip
Version Bump, fixes #379635
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/realpath/ChangeLog8
-rw-r--r--app-misc/realpath/metadata.xml4
-rw-r--r--app-misc/realpath/realpath-1.16.ebuild75
3 files changed, 84 insertions, 3 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index 08ba1c12181a..7d8430ba34b2 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.15 2011/03/27 21:52:55 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.16 2011/10/17 14:54:27 jlec Exp $
+
+*realpath-1.16 (17 Oct 2011)
+
+ 17 Oct 2011; Justin Lecher <jlec@gentoo.org> +realpath-1.16.ebuild,
+ metadata.xml:
+ Version Bump, fixes #379635
27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -realpath-1.15.ebuild,
-realpath-1.15-r2.ebuild:
diff --git a/app-misc/realpath/metadata.xml b/app-misc/realpath/metadata.xml
index 376efb8cd9e0..9fe17c2d7432 100644
--- a/app-misc/realpath/metadata.xml
+++ b/app-misc/realpath/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>shell-tools</herd>
-<longdescription lang="en">
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
The realpath utility finds the canonicalized absolute pathname of its
arguments in a similar way to readlink -f.
</longdescription>
diff --git a/app-misc/realpath/realpath-1.16.ebuild b/app-misc/realpath/realpath-1.16.ebuild
new file mode 100644
index 000000000000..d7e65815d98a
--- /dev/null
+++ b/app-misc/realpath/realpath-1.16.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.16.ebuild,v 1.1 2011/10/17 14:54:27 jlec Exp $
+
+EAPI="3"
+inherit eutils toolchain-funcs flag-o-matic prefix
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+ nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="!sys-freebsd/freebsd-bin"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libintl
+ elibc_IRIX? ( dev-libs/gnulib )
+ x86-interix? ( dev-libs/gnulib )
+ elibc_mintlib? ( virtual/libiconv )"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+
+ if use nls; then
+ # Unpack the .deb file, in order to get the preprocessed man page
+ # translations. This way we avoid a dependency on app-text/po4a.
+ mkdir deb
+ cd deb
+ unpack ${PN}_${PV}_i386.deb
+ unpack ./data.tar.gz
+ gunzip -r usr/share/man || die "gunzip failed"
+ fi
+}
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${P}-nonls.patch
+ epatch "${FILESDIR}"/${PN}-1.15-build.patch
+ epatch "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+ epatch "${FILESDIR}"/${PN}-1.15-prefix.patch
+ eprefixify common.mk
+}
+
+src_compile() {
+ tc-export CC
+ use !elibc_glibc && append-libs -lintl
+ [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
+ if [[ ${CHOST} == *-irix* || ${CHOST} == *-interix[35]* ]] ; then
+ append-flags -I"${EPREFIX}"/usr/$(get_libdir)/gnulib/include
+ append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/gnulib/$(get_libdir)
+ append-libs -lgnu
+ fi
+
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake VERSION="${PV}" SUBDIRS="src man $(use nls && echo po)" \
+ DESTDIR="${D}" install || die "emake install failed"
+ newdoc debian/changelog ChangeLog.debian || die
+
+ if use nls; then
+ local dir
+ for dir in "${WORKDIR}"/deb/usr/share/man/*; do
+ [ -f "${dir}"/man1/realpath.1 ] || continue
+ newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1 \
+ || die "newman failed"
+ done
+ fi
+}