summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-07-25 13:00:59 +0000
committerThomas Kahle <tomka@gentoo.org>2013-07-25 13:00:59 +0000
commita48ec09be102999fe5fa81b1874d568ce5fa8e8d (patch)
tree2f8a5684206d27ff07a002ab0f583738f4418320 /app-misc
parentAdd a patch to fix regexp encoding issues. Add ruby20. (diff)
downloadgentoo-2-a48ec09be102999fe5fa81b1874d568ce5fa8e8d.tar.gz
gentoo-2-a48ec09be102999fe5fa81b1874d568ce5fa8e8d.tar.bz2
gentoo-2-a48ec09be102999fe5fa81b1874d568ce5fa8e8d.zip
bump to 2.0.12, suppress update warnings (bug 478128)
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.12.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index f2ae22894c2d..3fb05f1cac32 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.60 2013/06/24 19:27:31 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.61 2013/07/25 13:00:59 tomka Exp $
+
+*anki-2.0.12 (25 Jul 2013)
+
+ 25 Jul 2013; Thomas Kahle <tomka@gentoo.org> +anki-2.0.12.ebuild:
+ bump to 2.0.12, suppress update warnings (bug 478128)
*anki-2.0.11-r1 (24 Jun 2013)
diff --git a/app-misc/anki/anki-2.0.12.ebuild b/app-misc/anki/anki-2.0.12.ebuild
new file mode 100644
index 000000000000..4fcdf24cb1b1
--- /dev/null
+++ b/app-misc/anki/anki-2.0.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.12.ebuild,v 1.1 2013/07/25 13:00:59 tomka Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ dev-python/send2trash
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty || die
+ sed -i -e /suppressUpdate=False/suppressUpdate=True/ \
+ aqt/profiles.py
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ python_domodule aqt anki
+ python_doscript anki/anki
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ fi
+}